Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

Post by synto » Tue Oct 29, 2019 9:05 am

Hi,
I'm trying to deploy my app (SDK 4.1) to a Samsung S7 Android device.
Unfortunately LiveCode compilation display an error: "unable to locate play service dependency base version 9.4.0"

I've installed all the Google API and Google Service library relative to SDK 4.1 with the SDK Manager.
But the error is still displayed .

Is it a Livecode or a SDK error, and how can i solve it ?
Last edited by synto on Mon Nov 04, 2019 10:22 am, edited 2 times in total.

sphere
Posts: 1117
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency

Post by sphere » Tue Oct 29, 2019 2:46 pm

Hi,

i don't know this error, but maybe this is mentioned:
sdk4.JPG
I'm not at my dev-pc so can't tell exactly.

Is there something special what you've added?

What is the Android version of the S7?

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency

Post by synto » Tue Oct 29, 2019 3:36 pm

Hi sphere, and thnaks for your help.
I've already checked this line but no effect.
The S7 SDK version is 8.

But the version number (9.4.0) on the error message make me think the problem come from Livecode...
But i'm on LCIndy 9.5.0 :( :?:

sphere
Posts: 1117
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency

Post by sphere » Tue Oct 29, 2019 4:37 pm

As far as i know the line should not matter, just to rule something out.

Can you post a screenshot of the error? So we can see the exact message.

ps and you have Oracle JAVA JDK 8.x.x installed? as some errors come due to the wrong JDK.

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency

Post by synto » Wed Oct 30, 2019 4:08 pm

I have reinstalled LCIndy and the Android SDK, but the error is still sidplayed, Here is a screenshot in attachment.

I have Java Oracle 8 SDK installed
Attachments
Capture d’écran_2019-10-30_16-05-42.jpg
Capture d’écran_2019-10-30_16-05-42.jpg (11.29 KiB) Viewed 4033 times

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency

Post by synto » Wed Oct 30, 2019 4:31 pm

After some tests, the problem come from the inclusion of Android Barcode Scanner or Android Barcode Library
Don't know why but those inclusion works some weeks ago.

Does someone use these features ?

sphere
Posts: 1117
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency

Post by sphere » Wed Oct 30, 2019 10:02 pm

Yes i use them and i don't see those errors.
Are you using Indy 9.5.0 stable?
and on which OS? looks like Linux.

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency

Post by synto » Thu Oct 31, 2019 10:25 am

Yeah i use last version Indy stable 9.5.0, on Linux Xubuntu (not supported by LC Team, because of XFCE window manager i think)

You don't have problems with Android Barcode ? Before this last error, i have lot of problem to display the scanner on precise coord on my phone screen, or just show the scanner...

sphere
Posts: 1117
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency

Post by sphere » Thu Oct 31, 2019 1:04 pm

Yes there are some issues. Not all options work together in the Barcode settings.
Maybe check the quality site to check on open issues for the barcode scanner.

I use Linux too to be able to support apps on it. But i merely work on Win10.
So i'm not an expert on Linux, Richard and Bogs are more into depth.
So maybe they chime in.

bogs
Posts: 5101
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to locate Play Service dependency

Post by bogs » Thu Oct 31, 2019 8:59 pm

sphere wrote:
Thu Oct 31, 2019 1:04 pm
Richard and Bogs are more into depth.
So maybe they chime in.
Heh, well, I could chime in, but as far as the problem goes, I wouldn't have much to offer. I don't have a mobile device, I don't develop for mobile, and I don't do anything with barcode scanners, so right off the top I'm pretty much out of the running.

As far as LC and XFCE go, I never had problems with the combo until the 8x series came along. I personally am not sure what changed, but it is an iffy proposition to try and get them to get along. MATE on the other hand, not nearly so much. So even there, I can't be of much help other than to suggest maybe trying your work on MATE or GNOME versions of 'buntu, something I am usually hesitant to suggest since I also tend to prefer the way XFCE does many things and since I don't use 'buntu (except for testing purposes to resolve problems).
Image

sphere
Posts: 1117
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency

Post by sphere » Thu Oct 31, 2019 9:24 pm

bogs wrote:
Thu Oct 31, 2019 8:59 pm
I wouldn't have much to offer
Well you gave some good advice :)

bogs
Posts: 5101
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to locate Play Service dependency

Post by bogs » Thu Oct 31, 2019 9:32 pm

Thanks :D It was worth what was charged for it :twisted:
Image

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency

Post by synto » Fri Nov 01, 2019 1:56 pm

Thanks to all of you for you interest to my Barcode issue

Now i can compile the app and install it on my mobile but can't show the Scanner. I already managed to display it and run it some time ago, but I do not remember how... :cry:
Maybe check the quality site to check on open issues for the barcode scanner.
Could you tell me where i can find this "quality site" please ?

SparkOut
Posts: 2407
Joined: Sun Sep 23, 2007 4:58 pm

Re: Unable to locate Play Service dependency

Post by SparkOut » Fri Nov 01, 2019 2:12 pm

This forum thread contains a link to an example quality site report, as well as being somewhat relevant to the barcode scanning feature:
viewtopic.php?p=181835#p181835

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency

Post by synto » Fri Nov 01, 2019 3:03 pm

Thanks SparkOut, i will read that.
With a simple stack i can display the Barcode Scanner but unfortunately not in my app (however with exactly the same properties)... :?: :?: :(

Thanks to my test the previewXXX attributes is the resolution of the camera, it have to be the same ratio of your widget width and height.

Post Reply

Return to “Android Deployment”