Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency

Post by synto » Fri Nov 01, 2019 3:45 pm

Thanks to the adblogcat, i see something that sound strange, perhaps the LC Team could explain it ?

W View : requestLayout() improperly called by com.livecode.widget.barcodescanner.CameraSourcePreview{7cf60d V.E...... ......I. 0,0-0,0} during layout: running second layout pass

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency - BarcodeScanner issue

Post by synto » Fri Nov 01, 2019 7:50 pm

Once again, the problem came from my stack that was corrupted. No idea where it comes from.
Here is my first post, and the precious help of Bogs:

https://forums.livecode.com/viewtopic.p ... de#p182492

Same solution and the Barcode Scanner is displayed now...

bogs
Posts: 5098
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to locate Play Service dependency - BarcodeScanner issue

Post by bogs » Fri Nov 01, 2019 8:22 pm

Glad to hear your getting some mileage out of that old chestnut synto :)
Image

sphere
Posts: 1116
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency - BarcodeScanner issue

Post by sphere » Fri Nov 01, 2019 10:44 pm

I learned some too, cause i did not know you could copy it that way.
Thanks guys!

sphere
Posts: 1116
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

Post by sphere » Thu Nov 14, 2019 7:20 pm

There was an answer on the list concerning the original error message:
So the required dependency is the "Google Repository" package (in the
"Extras" folder), and NOT the "Google Play services" package as one would
have thought.

synto
Posts: 40
Joined: Thu Jul 18, 2019 9:31 am
Location: Paris, Fr

Re: Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

Post by synto » Sun Dec 22, 2019 12:47 pm

Yes Sphere, i haven't noticed that but your right.
Unfortunately the Google Repository is no longer available in the Android SDK Manager, so you have to follow the instructions on this link
https://docs.gluonhq.com/getting-starte ... id-support

especially the command
./sdkmanager "extras;android;m2repository" "extras;google;m2repository"

KimD
Posts: 211
Joined: Wed Jul 08, 2015 5:51 am
Location: Wellington, New Zealand

Re: Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

Post by KimD » Wed Aug 19, 2020 6:32 am

Back to LC after a few months break. Same issue. I'm getting an "Unable to locate Play Service" error message when trying to create Android Standalone with the Barcode Scanner Widget. The error message goes away if I delete the widget. I'm not (yet) using any settings on the widget. Just adding the widget "out of the box" to my stack is enough to prevent the build of an Android standalone.

Win 10 + LC Indy 9.6 + Android Studio 4.0.1

I'm struggling to work out how to install Google Repository, even after I've looked at the link provided. Do I need to uninstall Android Studio before following these instructions, or do I follow these with Android Studio already installed?

If with Android Studio already installed - do I put the sdkmanager.bat file etc into one of the Android Studio directories or into its own directory?

Thanks in advance

Kim

sphere
Posts: 1116
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

Post by sphere » Wed Aug 19, 2020 1:04 pm

In the picture of page 1 of this thread you see the Google Repository as last line. That needs to be installed.

And to your question, I think you can do the Command Line thing if needed, while Android Studio is already installed.
When the path in your environment to the sdk is good then it should function, else you need to go to the correct folder to execute it from command line.
Otherwise it should be install-able from within Android Studio.

But if this is all not working then probably you need to add Google's Maven Repository, Check this: https://developer.android.com/studio/intro/update and scroll down below the image where Android SDK is highlighted to the blue section where it is explained.

Hope this helps.

KimD
Posts: 211
Joined: Wed Jul 08, 2015 5:51 am
Location: Wellington, New Zealand

Re: Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

Post by KimD » Thu Aug 20, 2020 3:04 am

Thanks Sphere. I tried a variety of methods for solving this before stumbling upon this -

https://quality.livecode.com/show_bug.cgi?id=22384

Following Panos instructions I had it fixed in a couple of minutes.

I've now got an Android barcode scanner deployed onto my test device. It works great. VERY impressed.

Kim

bangkok
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 928
Joined: Fri Aug 15, 2008 7:15 am

Re: Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

Post by bangkok » Thu Aug 20, 2020 5:12 am

KimD wrote:
Thu Aug 20, 2020 3:04 am
https://quality.livecode.com/show_bug.cgi?id=22384

Following Panos instructions I had it fixed in a couple of minutes.
Indeed ! It works perfectly (and so simple).

sphere
Posts: 1116
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to locate Play Service dependency - BarcodeScanner issue [SOLVED]

Post by sphere » Thu Aug 20, 2020 5:37 am

Great. !

Post Reply

Return to “Android Deployment”