Revigniter 404 error on LC community server

Are you using LiveCode to create server scripts or CGIs?

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
sphere
Posts: 1116
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Revigniter 404 error on LC community server

Post by sphere » Mon Aug 19, 2019 2:26 pm

Hi,

i'm trying to get revigniter running.
I've got the server running locally on xampp. (first test local before messing up my VPS)
created a folder lc in htdocs and copied the unzipped revigniter items in it
then according the user guide on revigniter.com ichanged the line in config.lc to put "localhost:81/lc/" into gConfig["baseUrl"]
Now when i open the url in Firefox localhost:81/lc/index.lc i thought it should open a page? Because in index.lc this line is still the same: put "system" into gRigA["systemFolder"]
But all i got is a 404 Page not found

Should it not serve a standard page or something?

Perhaps i should create another folder in applications? But then it's not clear where it looks for, what kind of name should the first file have?

Reading the Getting Started page refers back to Installation, [s]i found it not really helpful.[/s]
[s]So for me the User Guide is not quite clear on how to proceed.[/s] ---strike thru aint working---
EDIT--> i have to read more, then it's getting clearer how it works :).

How to go from here after revigniter is installed and base url is set?

Thanks for any help.
Last edited by sphere on Mon Aug 19, 2019 9:42 pm, edited 3 times in total.

rabit
Posts: 37
Joined: Wed May 31, 2006 8:30 am

Re: Revigniter 404 error on LC community server

Post by rabit » Mon Aug 19, 2019 4:45 pm

Hi sphere,

which version of LC server did you install?

Could you please tell me what the value of your server variable $_Server["PATH_TRANSLATED"] is?
To check this add the following lines:

Code: Select all

put “Path translated:” && $_Server["PATH_TRANSLATED"]
exit to top
anywhere in your index.lc file above the following line

Code: Select all

include gRigA["BASEPATH"] & "revigniter/RevIgniter" & gRigA["EXT"]


Could you please try out other uri protocols to retrieve URI strings
as described in application/config/config.lc?
-- Ralf Bitter

sphere
Posts: 1116
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Revigniter 404 error on LC community server

Post by sphere » Mon Aug 19, 2019 6:53 pm

Hi Ralf,

thanks for responding so quickly.
I installed LC community server 9.5.0

this is what it returned:
file "D:/server/xampp/htdocs/lc/index.lc"
row 5, col 5: put: preposition must be 'before', 'into' or 'after' (translated)
row 5, col 5: script: bad statement (translated)
YEs! your last hint did it :)
i've set this line:
put "AUTO" into gConfig["uriProtocol"]
to this:
put "QUERY_STRING" into gConfig["uriProtocol"]

AUTO - PATH_INFO - REQUEST_URI do not work
QUERY_STRING and ORIG_PATH_INFO do work ok

Can i leave it to QUERY_STRING?

Thanks a lot for your help and great work.
I hope i can use this.

SImply what i want to build is: Choose a supplier(with text and maybe an image) --> choose a category (text)-->choose a product(s)(text-price-image-howmany)--Choose maybe another category and so on-->order it & pay for it. Suplier gets notified and sends product out.

When this works then i want to put on my VPS.

Kind regards,
Jerry

edit--an extra subforum for revigniter would help a lot of people i think, it would help revigniter but also lc server

rabit
Posts: 37
Joined: Wed May 31, 2006 8:30 am

Re: Revigniter 404 error on LC community server

Post by rabit » Tue Aug 20, 2019 9:12 am

sphere wrote:
Mon Aug 19, 2019 6:53 pm

this is what it returned:
file "D:/server/xampp/htdocs/lc/index.lc"
row 5, col 5: put: preposition must be 'before', 'into' or 'after' (translated)
row 5, col 5: script: bad statement (translated)
Sorry, inadvertently used opening and closing quotation marks
in my code sample.

sphere wrote:
Mon Aug 19, 2019 6:53 pm

Can i leave it to QUERY_STRING?
Yes, leave it to QUERY_STRING.
-- Ralf Bitter

sphere
Posts: 1116
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Revigniter 404 error on LC community server

Post by sphere » Tue Aug 20, 2019 7:37 pm

Hi Ralf,

thanks for your respond.
I was reading last night the contents of the User Guide and will continue till i have read all.
Then will try some first steps and hopefully can use some scripts of my app to integrate.
But small steps :)

Post Reply

Return to “CGIs and the Server”