confused about LC,xCode and iOS versions

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2376
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

confused about LC,xCode and iOS versions

Post by jmburnod » Sat Sep 28, 2019 9:35 am

Hi All,
I'm confused about LC,xCode and iOS versions.
I use LiveCode 9.0.1, Xcode 9.4.1 Mac OS 10.13.5 iOS 11.4
I'm able to compile upload my app on my iPad
I understand i need to use Xcode 10.1 to upgrade an app on AppStore and i have to upgrade LC, xCode and iOS 12.4.

I read this on LiveCode.com
LiveCode 9.5.0, Xcode 10.1 Mac OS 10.13.4+ iOS 12.1

When i launch xCode 10.1 i get a warning ... 10.13.6 required

Thanks in advance for your lights

Jean-Marc

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 583
Joined: Fri Feb 06, 2015 4:03 pm

Re: confused about LC,xCode and iOS versions

Post by LiveCode_Panos » Mon Sep 30, 2019 9:20 pm

Hello Jean-Marc,

Indeed, Xcode 10.1 requires MacOS 10.13.6. The LC docs need to be updated.

You can upgrade from MacOS 10.13.5 to 10.13.6 using this link:

https://support.apple.com/kb/DL1969?locale=en_US

Kind regards,
Panos
--

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2376
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: confused about LC,xCode and iOS versions

Post by jmburnod » Mon Sep 30, 2019 10:24 pm

Thank you Panos
That is clearer for me
Kind regards
Jean-Marc

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2376
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: confused about LC,xCode and iOS versions

Post by jmburnod » Sat Oct 12, 2019 9:22 am

Hello Panos,
I get a strange warning from xCode 10.1
This iPad Air 2 (Model A1566) is running iOS 13.1.2 (17A860), which may not be supported by this version of Xcode.
But if i ignore it i can transfer my app on my iPad :D
Kind regards
Jean-Marc

Post Reply

Return to “iOS Deployment”