App upload errors via Application Loader - UPDATE

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
DRJ-UK
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 73
Joined: Tue Aug 23, 2011 2:50 pm
Location: United Kingdom
Contact:

App upload errors via Application Loader - UPDATE

Post by DRJ-UK » Thu May 15, 2014 9:36 pm

Colleagues

From today (15 May) the App store now requires all Apps to be build with Xcode 5.1.1 and the latest iOS SDK. We have just updated an iOS App built with LC6.6.1 and latest Xcode 5.1.1 and all goes well except the infamous ITMS-9000 alert is shown in Application Loader.
Application LoaderScreenSnapz001.png
ITMS-9000 Error
The response doesn't make sense given that the required build is based on the latest version of Xcode and the iOS SDK. Reported to Apple via the facility in Application Loader.

Anybody else had this problem following the iTunes Connect maintenance yesterday?

Will try again tomorrow and report back but doubt if this is a temporary glitch.
Last edited by DRJ-UK on Thu May 22, 2014 2:09 pm, edited 4 times in total.
LiveCode: Versions 8.0, 8.1
Xcode: Version 7.3, 8.0
Mac OS X: 10.11.12 (macOS Sierra) on iMacs with 3.4 Intel Core i7 & 16GB Memory

Creating Apps for educational professionals, effective teaching and learning.

ErikSchwartz
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7
Joined: Thu May 13, 2010 7:14 pm

Re: Application Loader ITMS-9000 errors

Post by ErikSchwartz » Thu May 15, 2014 10:19 pm

I got it too with my set up.

LC 6.6.2-rc-3 Build 4008
Xcode Version 5.1.1 (5B1008)

DRJ-UK
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 73
Joined: Tue Aug 23, 2011 2:50 pm
Location: United Kingdom
Contact:

Re: Application Loader ITMS-9000 errors UPDATE

Post by DRJ-UK » Fri May 16, 2014 9:16 am

Colleagues

AN UPDATE

Same problem this morning so decided to delve into the App package and look in detail at the LC generated Info.plist. Discovered the problem in the following element:

<key>DTXcodeBuild</key>
<string>5B130a</string>

This string is "built-in" to the LC application package for the various iOS builds supported. Changing this string value to reflect the current Xcode 5.1.1 (5B1008) will give the correct string data as follows:

<key>DTXcodeBuild</key>
<string>5B1008</string>

Using this change, the App was re-built with these changes applied and re-submitted successfully via Application Loader. This bug and worked solution has been reported to the LiveCode team via the Quality Control Centre (bug number 12434) at http://quality.runrev.com/show_bug.cgi?id=12434.

I am sure they can provide the "fixes" quickly so all users can submit successfully via Application Loader.

Dave
LiveCode: Versions 8.0, 8.1
Xcode: Version 7.3, 8.0
Mac OS X: 10.11.12 (macOS Sierra) on iMacs with 3.4 Intel Core i7 & 16GB Memory

Creating Apps for educational professionals, effective teaching and learning.

ErikSchwartz
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7
Joined: Thu May 13, 2010 7:14 pm

Re: Application Loader ITMS-9000 errors UPDATE

Post by ErikSchwartz » Fri May 16, 2014 6:01 pm

This fix worked for me.

Thanks Dave!

Randy Hengst
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 148
Joined: Thu Jun 29, 2006 4:16 pm

Re: Application Loader ITMS-9000 errors UPDATE

Post by Randy Hengst » Fri May 16, 2014 8:51 pm

Dave,

I've had the same problem… My novice is showing… I'm not sure how to go about applying the patch you described. Let me claify one thing… I open the plist in a text editor rather than Xcode, right?

randy

CALL-151
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 206
Joined: Wed Oct 20, 2010 11:00 am

Re: Application Loader ITMS-9000 errors UPDATE

Post by CALL-151 » Fri May 16, 2014 11:48 pm

Your fix didn't work for me. It does fix the incorrect DTXcodeBuild entry in the resulting info.plist file, but Application Loader reports numerous errors, mostly related to missing icons for various iPhone and iPod Touch models even though my standalone is built for the iPad only. Can you provide details about your apps that loaded successfully after modifying the LC settings.plist files? i.e. devices and iOS versions supported?

CALL-151
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 206
Joined: Wed Oct 20, 2010 11:00 am

Re: Application Loader ITMS-9000 errors UPDATE

Post by CALL-151 » Sat May 17, 2014 1:24 am

Started over with a fresh copy of 6.6.1, edited the settings.plist files with TextWrangler and used the modified 6.6.1 to build and submit without errors. Thank you.

DRJ-UK
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 73
Joined: Tue Aug 23, 2011 2:50 pm
Location: United Kingdom
Contact:

Re: Application Loader ITMS-9000 errors UPDATE

Post by DRJ-UK » Sat May 17, 2014 8:38 am

CALL-151 wrote:Started over with a fresh copy of 6.6.1, edited the settings.plist files with TextWrangler and used the modified 6.6.1 to build and submit without errors. Thank you.
Good to see this seems to have worked for others too. Important to note that this fix was only my solution for working with LC 6.6.1 (4005) although may work with other versions but has not been tested. Please note this is a temporary workaround and as such is "unsupported" and, therefore, not endorsed by LiveCode. The LiveCode team have yet to confirm the bug in the Quality Control Centre but clearly it is one!

Dave
LiveCode: Versions 8.0, 8.1
Xcode: Version 7.3, 8.0
Mac OS X: 10.11.12 (macOS Sierra) on iMacs with 3.4 Intel Core i7 & 16GB Memory

Creating Apps for educational professionals, effective teaching and learning.

CALL-151
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 206
Joined: Wed Oct 20, 2010 11:00 am

Re: Application Loader ITMS-9000 errors UPDATE

Post by CALL-151 » Sat May 17, 2014 1:18 pm

As far as I can tell, this issue was uncovered by a very recent change in the automated review process for submitted apps. As such, it looks to me like it will prevent App Stpre submissions for all apps built with versions of LC that support Xcode 5, up to and including LC 7.0 (dp 3). There seems to be some confusion about how to implement Dave's workaround, so here's a step-by-step description of what I did to modify a copy of LC 6.6.1:

Right click on LiveCode 6.6.1.app
Select Duplicate
Right click on LiveCode 6.6.1 copy.app
Select Show Package Contents
Navigate to Contents—> Tools—> Runtime—> iOS.
Inside each of the three Device folders is a file called Settings.plist. Open each one with a text editor (I used TextWrangler). Find 5B130a and replace it with 5B1008. Save the modified files.
Launch LiveCode 6.6.1 copy.app and use it to build your app for submission.

gaubatzsBUS9han
Posts: 10
Joined: Thu Sep 06, 2012 7:38 pm

Re: Application Loader ITMS-9000 errors UPDATE

Post by gaubatzsBUS9han » Mon May 19, 2014 11:45 pm

I can't thank you all enough for being there. This was a point of frustration but I knew that if I came to the forum I would get my answer. IT WORKED! Thank you for the detailed explanation of how to fix it.

Havanna
Posts: 52
Joined: Wed May 14, 2014 3:00 pm

Re: App upload errors via Application Loader - UPDATE

Post by Havanna » Thu May 22, 2014 6:34 pm

CALL-151 wrote:As far as I can tell, this issue was uncovered ...-
Thanks a lot, worked out of the box for me.

splash21
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 369
Joined: Sun Dec 19, 2010 1:10 am
Location: UK
Contact:

Re: App upload errors via Application Loader - UPDATE

Post by splash21 » Thu May 29, 2014 1:47 pm

Great fix - finding this thread this saved a lot of messing around - thanks. 8)
LiveCode Development & Training : http://splash21.com

gjtaylor99
Posts: 75
Joined: Mon May 09, 2011 3:01 pm
Location: Yarnton, Kidlington, Oxfordshire, England
Contact:

Re: Application Loader ITMS-9000 errors UPDATE

Post by gjtaylor99 » Sat May 31, 2014 5:05 pm

CALL-151 wrote:here's a step-by-step description of what I did to modify a copy of LC 6.6.1
Dear CALL-151 (and Dave and others on this thread)

Thank you so much for your great work in puzzling out what was wrong. There are so many variables that I had almost lost heart.

Your workaround was all I needed. After reading your workaround, withIn a matter of half an hour or so, I was successfully able to upload my app via iTunes Connect, and now iTunes Connect current Status = Upload Received. :D

Of course, there may be problems down the road, but for now I'm off to celebrate!
Cheers!
Geoff Taylor
Image

gjtaylor99
Posts: 75
Joined: Mon May 09, 2011 3:01 pm
Location: Yarnton, Kidlington, Oxfordshire, England
Contact:

Re: Application Loader ITMS-9000 errors UPDATE

Post by gjtaylor99 » Sat May 31, 2014 5:09 pm

gjtaylor99 wrote:iTunes Connect current Status = Upload Received
Update: iTunes Connect current Status = Waiting For Review :D
Geoff Taylor
Image

Post Reply

Return to “iOS Deployment”