Livecode stacks will not run on x86 emulator (HAXM MacOS)

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
richervin
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 54
Joined: Sat Sep 17, 2011 5:04 pm

Livecode stacks will not run on x86 emulator (HAXM MacOS)

Post by richervin » Mon Aug 27, 2012 10:50 pm

Livecode 5.5.2
MacOS Mountain Lion
Android 4.0.3 API Level 15 with Intel Atom (x86)
Intel HAXM driver installed

The emulator starts and runs correctly on my Intel MacOS with the expected speed improvement

Livecode compiles and installs the TickedOff app on the emulation device

Whenever the app is started, it immediately terminates with this error:
"Unfortunately, TickedOff has stopped"

This runs correctly on the same AVD image when restarted with ARM emulation

Is LiveCode supposed to be compatible with the x86 emulators? Is this a problem with LiveCode, or my configuration?
LiveCode 5.1.1 on Mac OS Mountain Lion
Attempting to develop for Android and iPhone
Currently on my third trial, and still finding LiveCode to be difficult for mobile applications in general, and particularly poor for Android

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5138
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS

Post by Mark » Tue Aug 28, 2012 1:25 am

Hi,

Since the LC binaries for Android are compiled for ARM processors, they can't run on (emulated) devices with x86 processors. Needless to say that this is not a bug.

Kind regards,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

richervin
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 54
Joined: Sat Sep 17, 2011 5:04 pm

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS

Post by richervin » Tue Aug 28, 2012 8:33 pm

I downloaded a random app from the internet to my x86 AVD. It installed and executed.

Why does a random APK file from the internet install and run, and the LC compiled app does not?

What is different about a LC app?
LiveCode 5.1.1 on Mac OS Mountain Lion
Attempting to develop for Android and iPhone
Currently on my third trial, and still finding LiveCode to be difficult for mobile applications in general, and particularly poor for Android

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5138
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS

Post by Mark » Tue Aug 28, 2012 9:09 pm

Hi,

Which app was that exactly? Got a link? Maybe I can tell you more if I have a look at it myself.

Kind regards,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

richervin
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 54
Joined: Sat Sep 17, 2011 5:04 pm

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS

Post by richervin » Tue Aug 28, 2012 11:26 pm

I downloaded it from from http://www.AppsApk.com/easy-history-cleaner/

I also tested android-sensor-box
LiveCode 5.1.1 on Mac OS Mountain Lion
Attempting to develop for Android and iPhone
Currently on my third trial, and still finding LiveCode to be difficult for mobile applications in general, and particularly poor for Android

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5138
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS

Post by Mark » Wed Aug 29, 2012 12:48 am

Hi,

I tried the app on a device with an ARM processor and that works fine, too. Actually, that's understandable, since Android is based on Java and you'd expect Java apps to be cross-platform (in this case cross-CPU). Perhaps there is an incompatibility with your specific configuration or perhaps there is a bug in the LiveCode engine that appears on x86 processors only. It is hard to say. It could also be a problem with the emulator itself. If this bug is specific to the emulator, then I wouldn't expect RunRev to fix this problem.

Kind regards,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

richervin
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 54
Joined: Sat Sep 17, 2011 5:04 pm

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS

Post by richervin » Wed Aug 29, 2012 1:55 am

I wanted to know if anyone else has used LiveCode with x86, and if/whether it is supposed to be supported.

I thought you were with RunRev. I'll submit a support request to them, when I get a chance.
LiveCode 5.1.1 on Mac OS Mountain Lion
Attempting to develop for Android and iPhone
Currently on my third trial, and still finding LiveCode to be difficult for mobile applications in general, and particularly poor for Android

sturgis
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 1682
Joined: Sat Feb 28, 2009 11:49 pm

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS

Post by sturgis » Wed Aug 29, 2012 2:04 am

livecode apk files are bundled with librevandroid.so which is in the armeabi folder. My guess is that this is a library compiled for arm specifically (probably not java at all) which would keep it from running on an x86 android emulator. Just a guess though.

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5138
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS

Post by Mark » Wed Aug 29, 2012 9:29 am

Hi,

Something like that was my original thought.

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

Hyberson
Posts: 1
Joined: Fri Oct 04, 2019 5:10 pm

Re: Livecode stacks will not run on x86 emulator (HAXM MacOS)

Post by Hyberson » Sat Oct 12, 2019 6:00 pm

Hello.

I am at the LiveCode Lessons stage.

At ( lessons livecode com / m / 4069 / l / 985962 livecode and android studio ) it reads: "[...] Remember that LiveCode can only use virtual devices with arm processors".

Is that true for the latest version of LC Community Plus ? If so
- what is the best alternative for testing an Android app (other than physical devices) ?
- how to proceed in order to make a virtual device (which I did not create with Android Studio) appear in the "Test Target" list?

Should I have created a new topic?

Regards,
Hyberson

Post Reply

Return to “Android Deployment”