LC8.1.6 crash with color picker

If you find an issue in LiveCode but are having difficulty pinning down a reliable recipe or want to sanity-check your findings with others, this is the place.

Please have one thread per issue, and try to summarize the issue concisely in the thread title so others can find related issues here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
dsquance
Posts: 37
Joined: Mon Jan 18, 2010 2:47 am

LC8.1.6 crash with color picker

Post by dsquance » Sat Dec 30, 2017 2:37 am

I'm only an occasional user and was working on a new stack for the first time in quite awhile. When I try to set a background color for the stack or an image, LC crashes. First it was with the crayons, and then I tried a different palette system and that crashed also. I haven't found a recent bug report on this--LC 8.0.x had a presumably similar bug which was said to be fixed. I don't have any way to log in anywhere else to report the bug. Is this just my system? Should I download a new copy?

Thanks,
Dave

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6860
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: LC8.1.6 crash with color picker

Post by FourthWorld » Sat Dec 30, 2017 3:23 am

dsquance wrote:
Sat Dec 30, 2017 2:37 am
I haven't found a recent bug report on this--LC 8.0.x had a presumably similar bug which was said to be fixed.
Where did you read about the earlier fix?
I don't have any way to log in anywhere else to report the bug.
Bug reports can be submitted here:
http://quality.livecode.com/
Is this just my system?
No way to know without further diagnosis.
Should I download a new copy?
When a bug is encountered in any software, it's helpful to try the latest build to see if the bug has been addressed.

A complete listing of release downloads is available here:
http://downloads.livecode.com/livecode/

The most current build is from Dec 23, v9.0 DP11. If you want to limit your testing to the 8.x series (v9 is coming along great but DPs generally contain new features which represent other potential issues not normally found in RCs) you might consider 8.1.9, released Dec 19.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

[-hh]
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2124
Joined: Thu Feb 28, 2013 11:52 pm
Location: Göttingen, DE

Re: LC8.1.6 crash with color picker

Post by [-hh] » Sat Dec 30, 2017 4:04 am

This is on MacOS only, since several months, starting with MacOS 10.13.

Every LC version from 6.x/7.x up to 8.1.5 crashes immediately when closing the color dialog. This bug has been removed in September 2017 for 8.1.7 and later but will never be removed for LC 6/7 and LC 8 < 8.1.6.

This has been backported to 8.1.6, so it should also work if you reinstall 8.1.6 from a _fresh_ download.

When using LC 6/7 or earlier LC 8 versions on MacOS 10.13 you have to make an own color chooser. Or use, for example, this one: http://livecodeshare.runrev.com/stack/854/
shiftLock happens

dsquance
Posts: 37
Joined: Mon Jan 18, 2010 2:47 am

Re: LC8.1.6 crash with color picker

Post by dsquance » Sat Dec 30, 2017 6:29 am

Thanks for the reply. I meant to indicate I was on a Mac with OS 10.13.2 and forgot. I will download 8.1.9 and expect that will be better. As to Richard's question about where I saw the report of a fix, it was on the list of bug reports. I did a search rather than attempting to submit a bug to see if there was one there already.

Dave

dsquance
Posts: 37
Joined: Mon Jan 18, 2010 2:47 am

Re: LC8.1.6 crash with color picker

Post by dsquance » Sat Dec 30, 2017 7:01 am

Well, LC8.1.9 didn't help. It wouldn't do anything. It appeared to load the stack, but after that nothing would respond. The Window menu said there were no windows open, and it all just locked up. I haven't restarted--will try again after that. Failing that, I will try v 9.0.0. I don't need the latest and greatest. I'd be happy with v. 7, but I gather from the earlier post that it won't work under High Sierra, either.

Dave

Post Reply

Return to “Bug Triage”