Problems compiling app with RunRev 4

Anything beyond the basics in using the LiveCode language. Share your handlers, functions and magic here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5145
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Re: Problems compiling app with RunRev 4

Post by Mark » Mon Jul 14, 2014 12:13 pm

Yep, this problem still exists. Usually, I just click OK and ignore it.

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

Mag
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 802
Joined: Fri Nov 16, 2012 10:51 pm

Re: Problems compiling app with RunRev 4

Post by Mag » Mon Jul 14, 2014 1:08 pm

Thank you Mark

Mag
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 802
Joined: Fri Nov 16, 2012 10:51 pm

Re: Problems compiling app with RunRev 4

Post by Mag » Mon Jul 14, 2014 1:17 pm

Another message started to appear...
Attachments
scr.png

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5145
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Re: Problems compiling app with RunRev 4

Post by Mark » Mon Jul 14, 2014 1:23 pm

Hi,

Are you using the commercial or the community version? In commercial versions, this can happen if the stack already has a password. Community versions should throw an execution error if a script tries to set a password. (Such an execution error looks different from this dialog window, but things are changing a lot lately, so maybe the dialog is now shown as a result of the execution error).

Kind regards,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

Mag
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 802
Joined: Fri Nov 16, 2012 10:51 pm

Re: Problems compiling app with RunRev 4

Post by Mag » Mon Jul 14, 2014 1:38 pm

Thank you for the info. I'm using a commercial version.

So I have to just set the pw for the Mainstack? Do you know if this will protect also the substacks?

Mark
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5145
Joined: Thu Feb 23, 2006 9:24 pm
Contact:

Re: Problems compiling app with RunRev 4

Post by Mark » Mon Jul 14, 2014 1:58 pm

Hi,

Probably, you tried to turn on password protection in the standalone settings for a stack that is protected by a password already. You have three options.

1) remove the password from that stack and just set all passwords for all stacks in the standalone settings
2) set the passwords of all stacks in the standalone settings, except for the password of the stack that is protected already
3) don't set any passwords in the standalone settings but use the message box (for example) to set the passwords of all mainstacks and substacks (except for the one that is already protected).

If you set the password of a mainstack, its substacks are still unprotected. You have to set a password for each mainstack and substack separately.

Kind regards,

Mark
The biggest LiveCode group on Facebook: https://www.facebook.com/groups/livecode.developers
The book "Programming LiveCode for the Real Beginner"! Get it here! http://tinyurl.com/book-livecode

Post Reply

Return to “Talking LiveCode”