Page 1 of 1

Creating Externals - Do you still need version 2.7 to do it?

Posted: Wed May 07, 2008 4:24 am
by bmont
In the article "Externals-Part1" it mentions that Revolution 2.7 is required.

Is this still true now that 2.9 has been released?

I know I should have posted to the "Using Externals and Plugins" forumk but I thought I may get better exposure here.

Thanks

Posted: Wed May 07, 2008 8:47 am
by Klaus
Hi bmont,

I am quite sure that this should be read "Rev >= 2.7 required"!


Best

Klaus

Posted: Wed May 07, 2008 3:21 pm
by bmont
I agree it should probably say this-if it is true. Here is the exact excerpt from the article. Also notice that it does not say XCode 2.4.x or higher:
Before we begin

Before going any further you will need:

Revolution 2.7.x (any edition should do)

Visual C++ 2005 - any edition including Express (if you want to build externals on Windows)

XCode 2.4.x (if want to build externals on Mac OS X)

The Revolution externals build environment: http://developer.runrev.com/externals/E ... mentV1.zip

A set of pre-constructed environments for each step in the tutorial article: http://developer.runrev.com/externals/N ... ticle1.zip

A cup of coffee (not strictly required, but I find it helps when coding in lower-level languages...)

Note: The need for Revolution 2.7.x is just because the External Creator assumes the new installation structure is 2.7 when setting up projects – the externals you build will operate in any Revolution version and edition.
The last bolded part seems to suggest that there was something special in release 2.7 concerning externals that is not present in subsequent releases.

Posted: Wed May 07, 2008 5:10 pm
by trevordevore
2.7 added a the "My Revolution Enterprise|Studio" folder to the Documents folder. In this folder you can store plugin, externals, etc. that are shared by all installations of Revolution >= 2.7. Previous to 2.7 plugins and externals were installed alongside the application.

The External Creator mentioned in the article is a Revolution stack that sets up the project files for XCode and Visual C++ and the stack assumes your install of Revolution will support the aforementioned externals folder.

You should be good to go in 2.9.

Posted: Wed May 07, 2008 11:06 pm
by bmont
Thank You.

Maybe the external article should be updated to make this clear.