Application Uploader Not work for .zip? - SOLVED

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

Post Reply
DR White
Posts: 516
Joined: Fri Aug 23, 2013 12:29 pm
Location: Virginia, USA

Application Uploader Not work for .zip? - SOLVED

Post by DR White » Fri Feb 16, 2018 8:52 pm

I have been uploading .zip files to the Apple Store for year, but now I get the following error:

ERROR ITMS-90529: "Invalid package. Applications built with sdk 9.0 or later must be packaged as proper IPA files."

I have redone my App ID and Profiles several times, but cannot get rid of this error.

What does this mean? HELP!

Thank You,

David
Last edited by DR White on Sat Feb 17, 2018 1:35 am, edited 1 time in total.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 688
Joined: Fri Feb 06, 2015 4:03 pm

Re: Application Uploader Not work for .zip?

Post by LiveCode_Panos » Fri Feb 16, 2018 11:16 pm

Hi David,

You need to to submit a .ipa file, not a .zip one.

See the section "Convert to .ipa" of this lesson:

http://lessons.livecode.com/m/4069/l/33 ... -app-store

Best,
Panos
--

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 688
Joined: Fri Feb 06, 2015 4:03 pm

Re: Application Uploader Not work for .zip?

Post by LiveCode_Panos » Fri Feb 16, 2018 11:19 pm

Moreover, if you build with LC 8.1.9 and Xcode 9.2, you'll need to add an "AppStore Icon" in the iOS standalone settings (in the "Icons" section). This should be a 1024x1024 .png file.

Best,
Panos
--

DR White
Posts: 516
Joined: Fri Aug 23, 2013 12:29 pm
Location: Virginia, USA

Re: Application Uploader Not work for .zip?

Post by DR White » Sat Feb 17, 2018 1:35 am

Panos,

That took care my problem beautifully!!

Thanks SO MUCH,

David

trevix
Posts: 559
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Application Uploader Not work for .zip? - SOLVED

Post by trevix » Sat May 09, 2020 3:07 pm

While I am not sure why this is not covered by LC or already available as a plug-in, I put together a small stack that convert the folder of a new standalone to an IPA file, ready to be uploaded to Apple with Transporter.

Below, the script.
I was wondering if it is correct (to me, it works) and if there is a way to get the path to the last created standalone (wich may change from ".../MyApp/iOS/MyApp.app" to ".../MyApp 2/iOS/MyApp.app" "... /MyApp 3/iOS/MyApp.app" etc.)

Code: Select all

--This stack is used to covert the folder that holds your iOS Standalone, 
--to a "application.ipa" file, ready to be uploaded to Apple using the Apple's Transporter.app

on mouseUp pButtonNumber
     answer folder "Select the folder containing your App:"
     put it into tFolderPath --name of the folder that conatins MyApp.app
     set the itemdelimiter to "/"
     put tFolderPath into tNewFolderPath
     put "PayLoad" into last item of tNewFolderPath
     put "mv" && kQuote(tFolderPath) && kQuote(tNewFolderPath) into tCommandRename --rename the folder to "PayLoad"
     put winshell (tCommandRename) into tShellstate
     if ": No" is in tShellstate then 
          beep
          Answer tShellstate
          exit mouseUp
     end if
     put "application.ipa" into last item of tFolderPath
     put "zip -r" &&  kQuote(tFolderPath) &&  kQuote(tNewFolderPath) into tCommandZip --Zip the folder and rename it "application.ipa"
     show widget "SpinnerZip"
     put winshell (tCommandZip) into tShellstate
     hide widget "SpinnerZip"
     if ": No" is in tShellstate then 
          beep
          Answer tShellstate
          exit mouseUp
     end if
     beep
     Answer "Done!"
end mouseUp

function winshell what
     if the platform = "Win32" then
          replace "/" with "\" in what
          set the hideConsoleWindows to true
     end if
     return shell(what)
end winshell

function kQuote what
     return quote & what & quote
end kQuote
Trevix
OSX 10.14.6 LC 9.6.0 Dp2 iOs 9.3>

trevix
Posts: 559
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Application Uploader Not work for .zip? - SOLVED

Post by trevix » Mon May 11, 2020 9:42 am

hmmm... it does not verify on Transporter:
ERROR ITMS-90072: "The IPA is invalid. It does not include a Payload directory."
I checked step by step the Terminal procedure and how my script repeat it, but while it woks with the terminal, it does not in my script.
It generate the IPA file and you can load it in transporter, but when you do a verify, it reports the error above. Even if eveything is on the desktop.
Trevix
OSX 10.14.6 LC 9.6.0 Dp2 iOs 9.3>

trevix
Posts: 559
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Application Uploader Not work for .zip? - NOT SOLVED

Post by trevix » Fri May 15, 2020 1:51 pm

Anyone know why is different doing it from the terminal or with shell commands from LC?
Trevix
OSX 10.14.6 LC 9.6.0 Dp2 iOs 9.3>

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”