LC 6.5.2 and Xcode version

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

Post Reply
Jellobus
Posts: 280
Joined: Tue Dec 10, 2013 2:53 pm

LC 6.5.2 and Xcode version

Post by Jellobus » Thu Aug 21, 2014 2:41 am

Hi all,

I like to use LC 6.5.2 but latest version Xcode 5.1.1 is not recognized by LC 6.5.2. it answers "The chosen folder is not a valid iOS SDK"
What version of Xcode should I install??? If older version is compatible with LC 6.5.2, is there any big difference between latest and older xcode in terms of performance?

current os x ver 10.9.4

thanks in advance!

Louis

Saman Sjr.
Posts: 49
Joined: Sat Nov 30, 2013 6:40 am

Re: LC 6.5.2 and Xcode version

Post by Saman Sjr. » Thu Aug 21, 2014 4:02 pm

copy paste from http://livecode.com/developers/guides/b ... tallation/

Snow Leopard
When running on Snow Leopard, LiveCode uses the iOS 5.0 SDK to produce device builds. This is available as part of Xcode 4.2.
The 4.3 and 5.0 simulators are supported on Snow Leopard.

Lion & Mountain Lion
When building for Arm v7 devices, LiveCode uses the iOS 6.1 SDK, available as part of Xcode 4.6.
When building for Arm v6 devices, LiveCode uses the iOS 5.1 SDK, available as part of Xcode 4.4.
If you wish to produce universal device builds (including both Arm v6 and Arm v7 instructions) you must have the iOS 5.1 and iOS 6.1 SDKs installed.
The 5.0, 5.1, 6.0 and 6.1 simulators are supported on Lion & Mountain Lion.

regard's
Saman Sjr.

Jellobus
Posts: 280
Joined: Tue Dec 10, 2013 2:53 pm

Re: LC 6.5.2 and Xcode version

Post by Jellobus » Fri Aug 22, 2014 7:22 pm

Hi Saman Sjr,

That's very clear explanation. :mrgreen: Thanks a lot for your advice!

Have a great weekend!

Louis

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”