App not working on android 2.2

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

Post Reply
classic12
Posts: 7
Joined: Wed Jan 04, 2012 4:34 pm

App not working on android 2.2

Post by classic12 » Thu Jan 05, 2012 12:45 pm

I have a app that queries a Mysql database and puts the results into a field.
Another button fires up the camera app and takes an image.

It runs okay on windows.
Runs okay on Iphone.

I have a android 2.2 tablet and 2.2 phone the mysql works okay but the camera does not fire up

on mouseUp
## This is the only way to name an imge BEFORE it is created
set the name of the templateimage to "harry"
mobilePickPhoto "camera" 100,100
if the result <> empty then
--put the result into image "Image1"
put "harry" into image "image1"
EXIT mouseup
end if

## Succes, now you can use the new image

end mouseUp

Also in the above code the image does not go into image1 it goes in the centre of the screen

Cheers


SteveW

Klaus
Posts: 12285
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: App not working on android 2.2

Post by Klaus » Thu Jan 05, 2012 3:30 pm

Hi Stev,

looks like you need to tell LiveCode that "harry" is an image 8)

Code: Select all

on mouseUp
  ## This is the only way to name an imge BEFORE it is created
  set the name of the templateimage to "harry"
  mobilePickPhoto "camera" 100,100
  if the result <> empty then
    put IMAGE "harry" into image "image1"

    ## not neccessary, since the handler is finished here!
    ## EXIT mouseup
  end if
end mouseup
And you might want to DELETE image "harry" after putting it into "image1", or just HIDE it.

Best

Klaus

classic12
Posts: 7
Joined: Wed Jan 04, 2012 4:34 pm

Re: App not working on android 2.2

Post by classic12 » Thu Jan 05, 2012 3:56 pm

I still get the same result. ie image in the middle of the screen.

Cheers

SteveW

classic12
Posts: 7
Joined: Wed Jan 04, 2012 4:34 pm

Re: App not working on android 2.2

Post by classic12 » Thu Jan 05, 2012 5:43 pm

Ok
If I use :
set the name of the templateimage to "harry"
set the loc of the templateimage to 100,100
mobilePickPhoto "camera", 100,100

it places it correctly.

Any work around for the android not calling the camera?

Klaus
Posts: 12285
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: App not working on android 2.2

Post by Klaus » Thu Jan 05, 2012 7:05 pm

Hi Steve,

please do only create ONE thread for ONE question the next time, thanks!


Best

Klaus

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”