Unable to build app for testing

The place to discuss anything and everything about running your LiveCode on Android

Moderators: FourthWorld, heatherlaine, Klaus, kevinmiller, robinmiller

Post Reply
trevix
Posts: 982
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Unable to build app for testing

Post by trevix » Tue May 28, 2024 7:36 pm

Hello.
Today I got again in the standalone install nightmare.
Using LC10dp8 on OSX 14.4.1 I tried to ADB install an updated standalone on a Android 13 TvBox.
Just yesterday I had no problems on doing this, but this morning I had to trick the Android BT permissions.
My Build Tool is 30.0.3 AND 31.0.0.
I've got the following error:
Screenshot 2024-05-28 alle 20.21.15.png
Then, I went to Android studio, delete the Build Tools 31.0.0 and added the 35.0.0-rc4 (the LC10dp8 release notes say to install the latest SDK tools...)
Now I get this error:
Screenshot 2024-05-28 alle 20.32.06.png
I have no idea of what I am doing, even after all these years.
Anyone can help please?
Thanks
Trevix
Trevix
OSX 14.3.1 xCode 15 LC 10 DP7 iOS 15> Android 7>

trevix
Posts: 982
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Unable to build app for testing

Post by trevix » Wed May 29, 2024 12:43 pm

For what I understand, reading from the web:
This error is telling us that our class was compiled at a higher version of Java than the version with which we tried to run it. More specifically, in this case we compiled our class with Java 11 and tried to run it with Java 8.
My LC setting hasn't changed.
Screenshot 2024-05-29 alle 13.31.34.png
So...what could be wrong?
Using ONLY build tool 30.0.3 brings the following error:
Attachments
Screenshot 2024-05-29 alle 13.39.36.png
Trevix
OSX 14.3.1 xCode 15 LC 10 DP7 iOS 15> Android 7>

trevix
Posts: 982
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Unable to build app for testing

Post by trevix » Wed May 29, 2024 3:23 pm

I am talking to myself... (sigh)! My day is gone on this damn problem.

As from viewtopic.php?f=53&p=225288 installe ONLY Build Tool 31.0.0
Now I get a different error:
Screenshot 2024-05-29 alle 16.15.57.png
And this is my LC10dp8 Android manifest (wouldn't know what version code we are talking about):
<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="${IDENTIFIER}"
android:versionCode="${VERSION_CODE}"
android:versionName="${VERSION_NAME}"
${INSTALL_LOCATION}>
${PUSH_PERMISSIONS}
${USES_PERMISSION}${USES_FEATURE}
<uses-feature android:name="android.hardware.bluetooth" android:required="false" />
<uses-feature android:name="android.hardware.bluetooth_le" android:required="false" />
<uses-feature android:name="android.hardware.location.gps" android:required="false" />
<uses-feature android:name="android.hardware.camera" android:required ="False"/>
<uses-feature android:name="android.hardware.faketouch" android:required="false" />
<uses-sdk android:minSdkVersion="${MIN_SDK_VERSION}" android:targetSdkVersion="${TARGET_SDK_VERSION}"/>
<supports-screens
android:largeScreens="true"
android:normalScreens="true"
android:smallScreens="true"
android:anyDensity="true" />
${QUERY_LIST}
<application android:label="${LABEL}" ${ICON} android:debuggable="false" ${ALLOW_HTTP_CONNECTIONS}>
<activity android:name="${NAME}"
android:theme="${THEME}"
android:screenOrientation="${ORIENTATION}"
android:configChanges="${CONFIG_CHANGES}"
android:windowSoftInputMode="stateHidden"
android:launchMode="singleTask"
android:hardwareAccelerated="${HARDWARE_ACCELERATED}"
android:exported="true">
<intent-filter>
<action android:name="android.intent.action.MAIN" />
<category android:name="android.intent.category.LAUNCHER" />
</intent-filter>
${NFC_FILTER}
${CUSTOM_URL_FILTER}
</activity>
${BILLING_ACTIVITY}
${PROVIDER}
${SERVICE}
${RECEIVER}
${PUSH_SERVICE}
${AD_ACTIVITY}
</application>
</manifest>
Trevix
OSX 14.3.1 xCode 15 LC 10 DP7 iOS 15> Android 7>

JereMiami
Posts: 122
Joined: Mon Nov 03, 2014 12:17 am

Re: Unable to build app for testing

Post by JereMiami » Sun Jun 16, 2024 4:13 pm

Same issues here.... Did you figure it out?

Right now, LC 9.6.11 successfully deploys using:
- macos - sonoma
- API 33
- Build tools 31.0.0 & 30.0.3 (both selected)
- JDK - jdk1.8.0_341

But on LC 10.0.0 -dp-8, these settings do NOT deploy to Android.

trevix
Posts: 982
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Unable to build app for testing

Post by trevix » Sun Jun 16, 2024 4:36 pm

Sorry, but it has been sometime and I am not sure to remember.

I think that it was something about my revsaveasandroidstandalone.livecodescript (which in my case had to be modified for my needs).
I started some conversation here (https://lessons.livecode.com/m/4069/l/9 ... oid-studio) but the problem was solved when I was told that, in my modified script, there were hidden extraneous characters. Bad paste, I guess.
Trevix
OSX 14.3.1 xCode 15 LC 10 DP7 iOS 15> Android 7>

Post Reply

Return to “Android Deployment”