Page 1 of 1

Amazon IAP v1-0 deprecated error

Posted: Tue Oct 13, 2020 11:23 am
by Hendricus
Using Livecode 9-6-0 I have developed an app for mobile. The app is a paid one and has 5 extra features unlockable as In-App-Purchase. The app is already deployed to the Google Play Store, passed the review, and is live.

Now, for Amazon deployment I just switched the radio button for the Amazon Store in the 'Standalone Application Settings' dialog for Android, and did a recompile using the 'Save as Standalone Application' option from the File-menu in the IDE. Uploading the resulting app to Amazon and submitting for review went fine.

The next day I received the following Error report from the Amazon Appstore Team:
During app review process we found that you are using IAP V1 in your app. This version of IAP is now deprecated and has been replaced by IAP V2. Migrate to the latest version. More info here
From the Amazon Developer web page I can see that this change took place in 2016.

How can I resolve this issue so that the compiler apk uses the correct IAP? Where does this problem come from and what is needed getting it fixed?

Re: Amazon IAP v1-0 deprecated error

Posted: Tue Oct 13, 2020 6:55 pm
by jacque
This sounds like something the team needs to address. I'd enter a bug report here : http://quality.livecode.com.

Re: Amazon IAP v1-0 deprecated error

Posted: Thu Oct 15, 2020 9:13 pm
by Hendricus
Thanks. I have submitted a report.