no internet on Android via Browser widget

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
Bevan
Posts: 18
Joined: Sat Jan 13, 2018 1:37 am

no internet on Android via Browser widget

Post by Bevan » Tue Apr 21, 2020 7:50 am

Hi,
I have an app on both app stores, iOS and Android, same code on both platforms. The app on an android phone running 5.1.1 works fine. However newer model Android phones (not sure the android version) the app does not allow for the browser to go to any URLs. I don't have a later model to test just yet.

I have the app settings as having a minimum 4.1 Jelley Beans, The internet application permissions is selected.

One error message that was provided me to is the following :

'net::ERR_CLEARTEXT_NOT_PERMITTED'

Does anybody have any ideas on what could be causing the issue? I can't figure out why it would work on the older phone and not on a later model. I haven't updated the Android SDK in a long time, but I would think that would only apply for testing out latest builds. I am running Livecode 9.6.0 (dp 3).

Thanks,
Bevan.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 8424
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: no internet on Android via Browser widget

Post by FourthWorld » Tue Apr 21, 2020 7:56 am

I don't know for sure, but anything mentioning "clear text" is likely related to encryption.

Do you have the encryption components checked in the Standalone Builder?
Richard Gaskin
LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems
LiveCode Group on Facebook
LiveCode Group on LinkedIn

Bevan
Posts: 18
Joined: Sat Jan 13, 2018 1:37 am

Re: no internet on Android via Browser widget

Post by Bevan » Tue Apr 21, 2020 8:47 am

I can't find any setting for encryption in the stand alone settings anywhere.

LCMark
Livecode Staff Member
Livecode Staff Member
Posts: 1097
Joined: Thu Apr 11, 2013 11:27 am

Re: no internet on Android via Browser widget

Post by LCMark » Tue Apr 21, 2020 8:52 am

@Bevan: Try making sure you are using `https` URLs in your app - newer Android devices are secure-by-default which means they disallow access to HTTP urls (the same as iOS has done since iOS7 or so).

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 8424
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: no internet on Android via Browser widget

Post by FourthWorld » Tue Apr 21, 2020 9:18 am

Thanks, Mark. That's what I was thinking with the encryption lib; hadn't occurred to me people might still be using http rather than https.

Does liburl depend on the encryption lib for ssl?
Richard Gaskin
LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems
LiveCode Group on Facebook
LiveCode Group on LinkedIn

Bevan
Posts: 18
Joined: Sat Jan 13, 2018 1:37 am

Re: no internet on Android via Browser widget

Post by Bevan » Tue Apr 21, 2020 2:36 pm

Thanks @FourthWorld & @LCMark, I will try https on all links.

I just checked and it's doing strange things. facebook url with http & https works fine.

using http on another URL link doesn't work. I will try https.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 8424
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: no internet on Android via Browser widget

Post by FourthWorld » Tue Apr 21, 2020 5:05 pm

When attempting to connect to Facebook via http it automatically upgrades the connection to https.

Many severs do, but not all.

Where https is needed it's a good idea to have the server force https.

Let us know how the switch to https works out on the URL you're still having trouble with.
Richard Gaskin
LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems
LiveCode Group on Facebook
LiveCode Group on LinkedIn

Post Reply

Return to “Android Deployment”