INSTALL_PARSE_FAILED_NO_CERTIFICATES error

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
astroboy
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 30
Joined: Wed Apr 09, 2008 8:05 pm

INSTALL_PARSE_FAILED_NO_CERTIFICATES error

Post by astroboy » Fri Aug 23, 2019 12:50 am

Hello LiveCoders

I'm trying to do a simple test by building a "Hello world" Android app on a x86 AVD, a featured achievement on LIveCode 9.5

However, it always fails in this stage:

Installation of app failed: adb: failed to install
/tmp/fileuhoo4r.apk: Failure
[INSTALL_PARSE_FAILED_NO_CERTIFICATES]
Failed to collect certificates from
/data/app/vmd/10435579641.tmp/base.apk
/data/app/vmd/10435579641.tmp/base.apk failed
verification of META-INF/CERT.SF: IO exception
verifying jar cert: Unable to parse the encoded bytes:
Encoding bytes too short]
Performing streamed Install

I already tried by using "Sign for development only", "Do not sign" and even "Sign with my key" and put my path to a "release.keystore", this key created as shown in your tutorials. Nothing worked.

My computer has been used on previous LiveCode versions to test Android apps, so I'm fairly sure it was configured properly...

Please help, I cannot figure out how to solve this...

astroboy
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 30
Joined: Wed Apr 09, 2008 8:05 pm

Re: INSTALL_PARSE_FAILED_NO_CERTIFICATES error

Post by astroboy » Sat Aug 24, 2019 1:10 am

I'll answer to myself, as it might be useful for other livecoders that could face the same error message.

It turned out that in Edit -> Preferences -> Mobile Support, at "JDK path" I had to remove the path that was pointing to a JDK 8 setup that always worked fine before 9.5 AFAIK, and put the path of the JRE that is included in Android Studio (in my setup, to /usr/local/android-studio/jre). That did the trick at least for me...

Post Reply

Return to “Android Deployment”