Deployment to Kindle Fire 7”

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
Markm49uk
Posts: 21
Joined: Sat Nov 24, 2018 4:47 pm

Deployment to Kindle Fire 7”

Post by Markm49uk » Mon Nov 26, 2018 11:35 am

Hi,

I just followed the instructions on setting up the environment for deployment to Android and everything appears to work fine. This is using the latest version of LiveCode and version 8 of the JDK. The build works fine. The app installs fine. I touch on the app to open it, it opens, pauses, screen changes colour slightly to a dark grey, app closes. No errors, no messages, nothing.

I followed the hour of code tutorial to create the Jungle Sounds stack. Works fine on desktop. I also built another stack simply displaying a button and a message when pressed. This also displays the same symptoms when deployed to the Fire tablet (it’s running Android 5.1).

Any ideas?

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 590
Joined: Fri Feb 06, 2015 4:03 pm

Re: Deployment to Kindle Fire 7”

Post by LiveCode_Panos » Mon Nov 26, 2018 11:58 am

Hello Markm49uk,

Welcome to LiveCode. Some (hopefully limited) Android devices are of an unsupported architecture for LiveCode 9.0.x. Most of these devices though do have a compatibility emulator to be able to run apps of a different architecture, but some don't.

However, LiveCode 9.1 DP-1 will bring support to the remaining Android architectures.

There is a bug report about this:

https://quality.livecode.com/show_bug.cgi?id=20954

Kind regards,
Panos
--

AxWald
Posts: 369
Joined: Thu Mar 06, 2014 2:57 pm

Re: Deployment to Kindle Fire 7”

Post by AxWald » Mon Nov 26, 2018 12:59 pm

Hi,
Markm49uk wrote:
Mon Nov 26, 2018 11:35 am
This is using the latest version of LiveCode [...]
Read in the comments to the bug report that Panos linked:
Apps built with LiveCode Indy 8.x.x installed and run just fine, but with LC 9.x.x onward, the apps upon launch just show a black screen and the OS throws an error notification.
You may want to try a less bleeding-edge version?

Have fun!
Livecode programming until the cat hits the fan ...

Markm49uk
Posts: 21
Joined: Sat Nov 24, 2018 4:47 pm

Re: Deployment to Kindle Fire 7”

Post by Markm49uk » Mon Nov 26, 2018 1:15 pm

Odd. So a later version of LiveCode is less compatible with Android than older versions? That bug appears to be related to non Arm architecture chips such as the Intel Atom chip. The Kindle fire is running a mediatek MT8127 which is Arm.

If that’s the case and I’m new here so bear with me how do I obtain an older version of LiveCode that will run and can I install the two versions alongside each other?

I’m in a trial period (I’m a FIleMaker developer by day) so my options may be limited.

Thanks for the help.

bogs
Posts: 3997
Joined: Sat Feb 25, 2017 10:45 pm

Re: Deployment to Kindle Fire 7”

Post by bogs » Mon Nov 26, 2018 1:24 pm

Well, if you don't need an indy version, you can go to https://downloads.livecode.com and get which ever version you need.
Image

richmond62
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 3811
Joined: Fri Feb 19, 2010 10:17 am
Location: Bulgaria

Re: Deployment to Kindle Fire 7”

Post by richmond62 » Mon Nov 26, 2018 3:12 pm

I have an ASUS tablet that runs Android on an INTEL chip.

Markm49uk
Posts: 21
Joined: Sat Nov 24, 2018 4:47 pm

Re: Deployment to Kindle Fire 7”

Post by Markm49uk » Mon Nov 26, 2018 4:36 pm

bogs wrote:
Mon Nov 26, 2018 1:24 pm
Well, if you don't need an indy version, you can go to /link that I can’t even quote!/ and get which ever version you need.
Thanks. I’ll give the community version a go.

Out of interest is the latest version of iOS supported on the latest version of the LiveCode product?

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 590
Joined: Fri Feb 06, 2015 4:03 pm

Re: Deployment to Kindle Fire 7”

Post by LiveCode_Panos » Mon Nov 26, 2018 4:55 pm

Out of interest is the latest version of iOS supported on the latest version of the LiveCode product?
Currently the latest version of iOS is 12.1, and the latest version of LC is 9.0.2 rc2 (released today).

*Deploying* to an iOS device running iOS 12.1 is supported.

Note that if you are on MacOS 10.13.6+ you'll need Xcode 10 for this, which you can find here:

https://developer.apple.com/download/more/

Support for *building* with Xcode 10.1 is not yet supported, but it won't make any difference really.

Kind regards,
Panos
--

Markm49uk
Posts: 21
Joined: Sat Nov 24, 2018 4:47 pm

Re: Deployment to Kindle Fire 7”

Post by Markm49uk » Mon Nov 26, 2018 5:21 pm

Thank you Panos.

bwmilby
Posts: 280
Joined: Wed Jun 07, 2017 5:37 am
Location: Henrico, VA
Contact:

Re: Deployment to Kindle Fire 7”

Post by bwmilby » Mon Nov 26, 2018 10:32 pm

What cert are you using? The apps must be signed to run. I just sign for development only. I have built stuff for my Fire 7. I’ve been considering a Fire HD 8 as an additional device.
Brian Milby

Script Tracker https://github.com/bwmilby/scriptTracker

Markm49uk
Posts: 21
Joined: Sat Nov 24, 2018 4:47 pm

Re: Deployment to Kindle Fire 7”

Post by Markm49uk » Tue Nov 27, 2018 1:02 am

bwmilby wrote:
Mon Nov 26, 2018 10:32 pm
What cert are you using? The apps must be signed to run. I just sign for development only. I have built stuff for my Fire 7. I’ve been considering a Fire HD 8 as an additional device.
Signed for development. Installed community edition 8.2 and the app worked fine. Some issue as mentioned above with the newer versions of LiveCode.

The Fire tablets are decent basic tablets - not in the iPad league of course but for only £50 they are decent test bed devices.

bwmilby
Posts: 280
Joined: Wed Jun 07, 2017 5:37 am
Location: Henrico, VA
Contact:

Re: Deployment to Kindle Fire 7”

Post by bwmilby » Tue Nov 27, 2018 1:29 am

Quite odd... I’ve been using the latest version of 9 just fine on my Fire 7 with MT8127. Fire OS 5.3.6.4
Brian Milby

Script Tracker https://github.com/bwmilby/scriptTracker

Markm49uk
Posts: 21
Joined: Sat Nov 24, 2018 4:47 pm

Re: Deployment to Kindle Fire 7”

Post by Markm49uk » Thu Nov 29, 2018 3:03 pm

bwmilby wrote:
Tue Nov 27, 2018 1:29 am
Quite odd... I’ve been using the latest version of 9 just fine on my Fire 7 with MT8127. Fire OS 5.3.6.4
Well that is odd. Not sure what else to check - I do have Google play services installed on the Fire. Perhaps this is causing issues.

SparkOut
Posts: 2030
Joined: Sun Sep 23, 2007 4:58 pm

Re: Deployment to Kindle Fire 7”

Post by SparkOut » Tue Jul 16, 2019 9:16 pm

I need to be able to deploy to Kindle Fire 7 and have encountered a problem on trying to test on the device:

Checking target device architecture failed: error:
device unauthorized.
This adb server's $ADB_VENDOR_KEYS is not set
Try 'adb kill-server' if that seems wrong.
Otherwise check for a confirmation dialog on your
device.

This happens on Windows 10 deploying via USB connection to Kindle Fire with USB debugging enabled. from both 9.5.0-dp1 and 8.1.10. Both deploy other apps to different Android devices, including an old Samsung tablet, from the same environment. I have done as suggested in some other forum threads related to the $ADB_VENDOR_KEYS error, and revoked USB debugging authorisations, disabled ADB and unplugged/replugged/reenabled/etc but no settings change the error.

Any ideas what the problem could be?

Post Reply

Return to “Android Deployment”