Problem after mobileComposeMail

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
NebulousBee
Posts: 5
Joined: Wed Nov 05, 2014 8:47 pm

Problem after mobileComposeMail

Post by NebulousBee » Fri Oct 02, 2015 2:20 am

Hi all,
I am developing an Android app for my own use, with Livecode Community Edition 7.01 rc2, I am testing my stack on an Android 4.4.2 phone (HTC One). I am using mobileComposeMail() and it's working. When the code gets to that line, my phone's email client pops up and there is the email, just as I want it.

That's all great. The problem comes in with what happens next. It's not at all clear form the help what is supposed to happen next, but when I cancel sending the message from that screen, I am taken back to my email client's main screen, and my app is stuck. Since I am looking at my email client, I have to switch task back to my Livecode app. When I do that, I am taken right back to the email client again, on the send message screen. It's like the Livecode app doesn't know to take control back.

If I remember this problem I can press my phone's Back button and then I am back to my stack. Is that how this is supposed to work? Seems odd and I couldn't expect another user to know that, could I?

Is there any way to add logic to my stack to avoid this? Thanks for any help.

(Update: Edited for correct behaviors... I'm still not sure this is how it is supposed to work.)

Post Reply

Return to “Android Deployment”