the media player not working on android??

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Simon
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 3901
Joined: Sat Mar 24, 2007 2:54 am
Location: Palo Alto

Re: the media player not working on android??

Post by Simon » Sun Oct 26, 2014 2:35 am

I guess I left out the Dictionary entry is actually "play file" if you look up just "play" it will show desktop and iOS only. :?


Simon
I used to be a newbie but then I learned how to spell teh correctly and now I'm a noob!

rumplestiltskin
Posts: 222
Joined: Wed Jun 21, 2006 7:33 pm
Location: West of the Pecos
Contact:

Re: the media player not working on android??

Post by rumplestiltskin » Sun Oct 26, 2014 2:39 am

Simon,

What a forehead-slapping moment! I would assume that a video file would require all of the mobileControl nonsense because there would need to be a real player object in which the video would play. Luckily, my stack just needs a couple of audio files. Moving the audio file into the same folder as the stack simplified the specialFolderPath issue.

Thanks again!

Barry

PS - This line of code actually worked in Android:

Code: Select all

play specialFolderPath ("engine") & "/Click(96kb).mp3"

newtronsols
Posts: 192
Joined: Tue Mar 11, 2014 12:57 pm

Re: the media player not working on android??

Post by newtronsols » Sun Oct 26, 2014 7:36 am

A few things I found when copying an mp3 etc to play on Android
-I had to tick 'copy referenced files': so it contained _referenced files
- I had to be careful to match the file name so if myBest.mp3 not to use mybest.mp3 in the app.
- I had to use "engine" in the specialfolderpath

Another useful tip is: wait until the sound is done

rumplestiltskin
Posts: 222
Joined: Wed Jun 21, 2006 7:33 pm
Location: West of the Pecos
Contact:

Re: the media player not working on android??

Post by rumplestiltskin » Sun Oct 26, 2014 3:25 pm

newtronsols wrote:A few things I found when copying an mp3 etc to play on Android
-I had to tick 'copy referenced files': so it contained _referenced files
- I had to be careful to match the file name so if myBest.mp3 not to use mybest.mp3 in the app.
- I had to use "engine" in the specialfolderpath

Another useful tip is: wait until the sound is done
- 'copy referenced files' checkbox I left disabled. No problems encountered.
- case sensitivity in Android?? I just checked online and, apparently, it is. The moron over at Google who made this decision should be beaten with sharp sticks.
- "engine" in the specialfolderpath. Yep, working perfectly as you instructed. I just had to move my audio files into the same directory as my .livecode file and they were then stored properly in the .apk
- 'wait until the sound is done' Oh, yes; that was a very early discovery (actually, a response to my cry for help here in the forum a number of years ago).

Thanks very much,
Barry

Post Reply

Return to “Android Deployment”