Unable to test install after Sonoma + LC10DP7 update

The place to discuss anything and everything about running your LiveCode on Android

Moderators: FourthWorld, heatherlaine, Klaus, kevinmiller, robinmiller

Post Reply
trevix
Posts: 946
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Unable to test install after Sonoma + LC10DP7 update

Post by trevix » Sat Jan 20, 2024 1:22 pm

I recently updated my Mac to Sonoma and installed LC10DP7.
Now I cannot test install on Android 11 devices because i get the following error:
Screenshot 2024-01-20 alle 13.09.06.png
This stuff is way too complex for me. I hope someone can give me a hint...Thanks
These are my Standalone settings:
Screenshot 2024-01-20 alle 13.10.19.png
And this is my Android manifest (the same I was using with LC10dp6 on Mac Monterey):
<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
package="${IDENTIFIER}"
android:versionCode="${VERSION_CODE}"
android:versionName="${VERSION_NAME}"
${INSTALL_LOCATION}>
${PUSH_PERMISSIONS}
${USES_PERMISSION}${USES_FEATURE}
<uses-feature android:name="android.hardware.bluetooth" android:required="false" />
<uses-feature android:name="android.hardware.bluetooth_le" android:required="false" />
<uses-feature android:name="android.hardware.location.gps" android:required="false" />
<uses-feature android:name="android.hardware.camera" android:required ="False"/>
<uses-feature android:name="android.hardware.faketouch" android:required="false" />
<uses-sdk android:minSdkVersion="${MIN_SDK_VERSION}" android:targetSdkVersion="${TARGET_SDK_VERSION}"/>
<supports-screens
android:largeScreens="true"
android:normalScreens="true"
android:smallScreens="true"
android:anyDensity="true" />
${QUERY_LIST}
<application android:label="${LABEL}" ${ICON} android:debuggable="false" ${ALLOW_HTTP_CONNECTIONS}>
<activity android:name="${NAME}"
android:theme="${THEME}"
android:screenOrientation="${ORIENTATION}"
android:configChanges="${CONFIG_CHANGES}"
android:windowSoftInputMode="stateHidden"
android:launchMode="singleTask"
android:hardwareAccelerated="${HARDWARE_ACCELERATED}"
android:exported="true">
<intent-filter>
<action android:name="android.intent.action.MAIN" />
<category android:name="android.intent.category.LAUNCHER" />
</intent-filter>
${NFC_FILTER}
${CUSTOM_URL_FILTER}
</activity>
${BILLING_ACTIVITY}
${PROVIDER}
${SERVICE}
${RECEIVER}
${PUSH_SERVICE}
${AD_ACTIVITY}
</application>
</manifest>
Last edited by trevix on Sun Jan 21, 2024 7:35 pm, edited 1 time in total.
Trevix
OSX 14.3.1 xCode 15 LC 10 DP7 iOS 15> Android 7>

trevix
Posts: 946
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Unable to test install after Sonoma + LC10DP7 update

Post by trevix » Sun Jan 21, 2024 7:35 pm

Update:
After some check on the android SDK tool manager, testing using USB to a hardware Android 11 phone I now got this error:
Unable to build app for testing: could not link resources - error:
/ private/var/folders/jb/9zq6s6s11j90p38pk8gwxnfh0000gn/T/Temporaryltems/tmp.36619.NBcdDa7v/AndroidManifest.ml:27:
error: resource mipmap/ic_launcher (aka com.trevix.it.segnapunto:mipmap/ic_launcher) not found.
error: failed processing manifest.
As before, this error is not very clear.
If "ml:27" refers to a line number on the manifest, the lines is:
android:launchMode="singleTask"
What the hell does it mean?
Trevix
OSX 14.3.1 xCode 15 LC 10 DP7 iOS 15> Android 7>

trevix
Posts: 946
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Unable to test install after Sonoma + LC10DP7 update:SOLVED

Post by trevix » Mon Jan 22, 2024 9:41 am

Amazing how much time is wasted for things that should never happen...

While I waited for some learned response, I tried to re-link the "Icon Res Folder" field of the LC Android standalone settings.
Voilà: without (to my knowledge) changing anything, now LC installs the standalone on Android without problems.
Trevix
Trevix
OSX 14.3.1 xCode 15 LC 10 DP7 iOS 15> Android 7>

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 818
Joined: Fri Feb 06, 2015 4:03 pm

Re: Unable to test install after Sonoma + LC10DP7 update

Post by LiveCode_Panos » Wed Jan 24, 2024 3:17 pm

Hello Trevix,

Did you originally develop this stack (and set the path to the res folder) in the same machine?

I am wondering if the "old" stored path to the res folder (which is stored as a custom property of the stack) was an absolute path that was pointing to a location in your old machine, and by re-setting the res path it now points to a valid path in your new machine.

Kind regards,
Panos
--

trevix
Posts: 946
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: Unable to test install after Sonoma + LC10DP7 update

Post by trevix » Wed Jan 24, 2024 4:27 pm

Yes: same machine, same account, same everything. I just updated the OSX, Xcode and LC. Then tried to test/install my last (working) standalone on Android.
The path to the icon res folder wasn't touched by me (/Users/trevix/AndroidStudioProjects/Segnapunto2/app/src/main/res). When I established the path then everything started working again.

By the way, in the standalone settings it would be nice if long path could scroll or be selected (as to see it all) or that the button could remember the last position, so to see were it is pointing at.
Trevix
OSX 14.3.1 xCode 15 LC 10 DP7 iOS 15> Android 7>

Post Reply

Return to “Android Deployment”