Distorted view on emulator

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
sphere
Posts: 1047
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Distorted view on emulator

Post by sphere » Sun Jun 21, 2020 1:52 pm

Hi,
maybe i asked this before but it is rather annoying (read something more heavier here)....
Anyone knows why LC apps always look distorted on the Android Emulator? i'm using an x86-64 Android 9 emulator now, but it happened also on the previous types.
Other apps look good on the emulator.
The apps look good on real device. But for development it would be very convenient when it looks how it should be on the emulator. On iOs emulator these artifacts are not present.

NOT ok: double-partly images
strange (Phone).PNG
NOT ok: double-partly images thru a button
strange2 (Phone).PNG
OK:
strange3 (Phone).PNG
Is there a solution for it?
Thanks!

sphere
Posts: 1047
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Distorted view on emulator

Post by sphere » Wed Jun 24, 2020 11:51 am

Nobody ?

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5406
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Distorted view on emulator

Post by jacque » Wed Jun 24, 2020 4:57 pm

I stopped using the emulator years ago, it's much faster to just plug in the phone. But your images look like an emulator bug to me, especially since the problem doesn't happen on a real device.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

sphere
Posts: 1047
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Distorted view on emulator

Post by sphere » Wed Jun 24, 2020 8:00 pm

jacque wrote:
Wed Jun 24, 2020 4:57 pm
I stopped using the emulator years ago, it's much faster to just plug in the phone. But your images look like an emulator bug to me, especially since the problem doesn't happen on a real device.
Yes but the x86 emulator is real fast to deploy a test on.
The emulator could be the culprit, but i'm not yet 100% convinced, becasue other apps (non-lc) do look good, no strange artifacts.

Noyr yhis is on win10. I could test on Mac or Linux with the Android emulator, not tried that yet.

SparkOut
Posts: 2230
Joined: Sun Sep 23, 2007 4:58 pm

Re: Distorted view on emulator

Post by SparkOut » Wed Jun 24, 2020 8:41 pm

I don't know what to suggest for a definite solution, but I guess it is worth asking:-
Whether you have set accelerated rendering on the stack?
Whether you have made any compositing settings?
Whether you have set "dynamic" or "static" layerMode on any objects?
Whether you have made any fullscreenMode settings?

sphere
Posts: 1047
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Distorted view on emulator

Post by sphere » Wed Jun 24, 2020 9:26 pm

SparkOut wrote:
Wed Jun 24, 2020 8:41 pm
I don't know what to suggest for a definite solution, but I guess it is worth asking:-
Whether you have set accelerated rendering on the stack? ---> Yes i have
Whether you have made any compositing settings? ---> Nope
Whether you have set "dynamic" or "static" layerMode on any objects? ---> only where datagrids are involved
Whether you have made any fullscreenMode settings? ---> I always use exact Fit (not always ok but...)
Thanks, as you see i've putted my answers within the quoting

SparkOut
Posts: 2230
Joined: Sun Sep 23, 2007 4:58 pm

Re: Distorted view on emulator

Post by SparkOut » Wed Jun 24, 2020 11:26 pm

Ok, out of that I would suggest trying to see if setting accelerated rendering as false makes a difference in the emulator.
If that doesn't help, I would clutch at the last straw and turn off fullscreenMode temporarily and try another mode after that.
If none of the above makes a difference then I would probably have one last go at something like uninstalling the emulator and installing it again, before giving up and testing on real device and not using the emulator, or at least ignoring the screen rendering issues.

sphere
Posts: 1047
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Distorted view on emulator

Post by sphere » Thu Jun 25, 2020 5:30 pm

Thanks Sparkout, i will some suggestions. I'll be back 8)

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5406
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Distorted view on emulator

Post by jacque » Thu Jun 25, 2020 5:55 pm

You can also try forcing a redraw of the card:

Code: Select all

set the backcolor of this card to the backcolor of this card 
I use that when LC messes up the card draw, though since it only happens in the emulator it may not be worth the trouble. It won't hurt anything though.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

sphere
Posts: 1047
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Distorted view on emulator

Post by sphere » Thu Jun 25, 2020 8:26 pm

I did all suggestions, except for re-installing the emulator. Because it was the same on previous emulators and on another one i use.

Thanks Sparkout and Jaqcue.
Also in the settings of the emulator, none of the display settings makes any difference.
setadroid.png
So i will test the emulator on Linux and on MacOs, lets see

sphere
Posts: 1047
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Distorted view on emulator

Post by sphere » Fri Jun 26, 2020 11:31 am

So i tested on Mac and a Android 9.0 Emulator:
Screen Shot 2020-06-25 at 21.53.29 (Phone).png
Screen Shot 2020-06-25 at 22.04.47 (Phone).png
No strange artifacts.
Note that this is on the same PC hardware and a Hackintosh.

So it seems to me a combination of LC and the Android Emulator on Windows.

And since other apps than LC look ok, where is the cause of this fault?
Maybe i can contact Google expecting no answer, but one never knows.

sphere
Posts: 1047
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Distorted view on emulator

Post by sphere » Sat Jun 27, 2020 8:42 pm

For Windows i reinstalled Bluestacks.
Here the apps are looking good.
Via CMD dos-prompt i entered this:

Code: Select all

adb connect localhost:5555
so now Livecode can see Bluestacks too, and i can deploy a test directly from LC. (Google's emulator is seen on port 5554)

I installed also Google and Text-to-speech as my app uses speech. Follow this https://www.reddit.com/r/BlueStacks/com ... nal_guide/ on how to enable it in Bluestacks correctly.

Now i have to find a way to get Dutch as nr1 language, because Bluestacks seems to refuse and thus is the English voice speaking Dutch. which sounds funny.

Post Reply

Return to “Android Deployment”