Success with testing in-app purchases

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
KimD
Posts: 211
Joined: Wed Jul 08, 2015 5:51 am
Location: Wellington, New Zealand

Success with testing in-app purchases

Post by KimD » Mon Jul 04, 2016 1:20 am

I've just spent a couple of day's trying to work out how to test IOS in-app purchases. I'm so excited to have (at last) got a successful test that I thought that I would post the winning formula (LC8.0.1 / OSX 10.11.5 / IOS 7.1.2) :

1) Create your app with IOS in-app purchases as outlined in LC's tutorial -

http://lessons.livecode.com/m/4069/l/18 ... e-appstore

The key field is the ProductID. Note that:
- in Android / Play Store the ProductID is prefixed by the app identifier (from StandAlone Settings); but
- in IOS / App Store the ProductID is NOT prefixed by the app identifier

2) Create an email address (e.g. on Gmail) for a test user

3) In iTunes Connect > Users & Roles > Sandbox Testers - Create a test user with the email address that you created in step 2. Note that you don't need to add any credit card / bank details.

4) Logon to the email address that you created in step 2, find the email from Apple, and verify your test user

5) On your test device - go into Settings > iTunes & App Store - and sign out of your current Apple ID. Do NOT sign back in with your test user ID.

I re-booted my test device after this step - but I don't know whether this was needed.

6) Use Xcode to load your app onto your test device.

7) Start your app on your test device; and press the in-app purchase button that you want to test. You will be prompted to enter an Apple ID - enter the ID that you created in step 3

At this point a I get a "Confirm your in-app purchase" pop-up box, with "Environment Sandbox" at the bottom. After I confirmed, my number of widgets was incremented Oh that was so good to see!!!

Note that on iTunes Connect my app has status "Prepare for Submission", and my in-app purchases have the status "Ready to Submit". I've also got a warning message "Your first In-App Purchase must be submitted with a new app version. Select it from the app’s In-App Purchases section and click Submit", but none of this stopped the test from working.

Jim H
Posts: 2
Joined: Mon Aug 22, 2016 1:09 pm

Re: Success with testing in-app purchases

Post by Jim H » Mon Aug 22, 2016 1:38 pm

Kim - I am at exactly the same point with my app but having tested it on the device I get an error from Application Loader when submitting it to the App Store - Error ITMS-90035. Invalid signature. There is a post on the Apple Support Forum about this error (enter 90035 into the search and it's the fourth post) which says the fix is to renew your Apple Worldwide Developer Relations Intermediate Certificate. I have done this but unfortunately the error still persists. I am looking into team based code signing mentioned in the post but let me know if you are able to load your app onto the App Store.

Jim

KimD
Posts: 211
Joined: Wed Jul 08, 2015 5:51 am
Location: Wellington, New Zealand

Re: Success with testing in-app purchases

Post by KimD » Mon Aug 22, 2016 11:03 pm

Hi Jim

Yes - I've been able to load my LC 8 app onto the App Store, and in-app purchases are working. The link is below if you want to see it ;-)

https://itunes.apple.com/app/id1125257501

Unfortunately I'm not going to be much help to you - as I'd score myself 1 out of 10 in terms of IOS experience. I have one suggestion. Are you definitely using the right profile setting in Standalone App Settings > IOS? I use my DEVELOPMENT profile to deploy my app to my test device, then switch to my PROVISIONING profile when submitting my app to Apple via the Application Loader.

Good luck

Kim

Jim H
Posts: 2
Joined: Mon Aug 22, 2016 1:09 pm

Re: Success with testing in-app purchases

Post by Jim H » Thu Aug 25, 2016 12:42 pm

Thanks Kim. Will keep trying.

Jim.

Batninja
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 53
Joined: Sat Oct 15, 2011 9:43 am

Re: Success with testing in-app purchases

Post by Batninja » Mon Aug 17, 2020 8:52 am

Hi, sadly the app is not working on my iPhone 6s running IOS 13.6, downloaded from app store, icon is displayed, when launched it opens and closes immediately. Tried restarting device with no success, same with iPad Air.

Pity really as wanted to see the in app purchase working.

Post Reply

Return to “iOS Deployment”