iOS8 encryption build problem

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
Chipp
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 27
Joined: Sat Apr 08, 2006 9:50 am
Location: Austin, TX
Contact:

iOS8 encryption build problem

Post by Chipp » Mon Mar 02, 2015 10:58 pm

I have a unique iOS8 problem, which seems difficult to solve and thought someone might be able to shed some light.

I'm using some protected library stacks from the LiveCloud folks. Everything worked fine in my old computer. Now when I run it, things work ok, even in the simulator. But when I build a standalone and install it on my iPhone 6+, I get the following errors (2,3) with the settings I have (1).

Image

This is a brand new Mac, and I noticed the permissioning wasn't set up properly for some reason. I used Disk First Aid to 'fix permissions' which FIXED things working in the simulator (got same message in simulator BEFORE fixing permissions). I deleted and reinstalled LC 7.0.1 and LC 7.0.3 after the fixed perms.

I still get the encryption issue on my iPhone. I *think* it might be some sort of standalone build problem (included is standalone) where LC doesn't have the correct perms for installing the encryption libs? I really don't know and am at my wits end. I would be immensely grateful for any help anyone may provide.

Link to iOS8 app
https://dl.dropboxusercontent.com/u/378 ... er.app.zip
[url=http://www.altuit.com/webs/hemingway/Products/AltuitProducts.htm]Visit Altuit, creator of ButtonGadget and other Rev add-ons[/url]

Chipp
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 27
Joined: Sat Apr 08, 2006 9:50 am
Location: Austin, TX
Contact:

Re: iOS8 encryption build problem

Post by Chipp » Tue Mar 03, 2015 12:22 am

FWIW, we can get it running in 6.7.3, just not 7.x. Not my computer's permissioning issues. I'll let folks know what I find out.
[url=http://www.altuit.com/webs/hemingway/Products/AltuitProducts.htm]Visit Altuit, creator of ButtonGadget and other Rev add-ons[/url]

Chipp
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 27
Joined: Sat Apr 08, 2006 9:50 am
Location: Austin, TX
Contact:

Re: iOS8 encryption build problem

Post by Chipp » Tue Mar 03, 2015 8:07 pm

Turns out encryption has been broken in iOS 7+. Bug filed.
[url=http://www.altuit.com/webs/hemingway/Products/AltuitProducts.htm]Visit Altuit, creator of ButtonGadget and other Rev add-ons[/url]

Post Reply

Return to “iOS Deployment”