Backwards compatibility needed for updates not possible

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
Posts: 111
Joined: Mon Nov 07, 2011 4:10 am
Location: San Jose area, California, USA

Backwards compatibility needed for updates not possible

Post by SusanB » Mon Feb 09, 2015 5:57 pm

When I submit my latest build using LC 6.7, Application Loader tells me that it must be compatible with all devices I originally built it for in 2013. The old version of LC went back as far as iPhone 3.1.3, but 6.7 only allows for 4.3 or later. Is there a work around for this? Nobody with iOS8 is going to be able to use this app if I can't get this upgrade uploaded. If I want to support iOS8, then it seems I need to remove my current app and replace it with the latest which only 5.1.1 or later iPhones. Maybe that's not such a terrible thing, anyway.

ERROR ITMS-90101: "This bundle does not support one or more of the devices supported by the previous app version. Your app update must continue to support all devices previously supported. You declare supported devices in Xcode with the Targeted Device Family build setting. Refer to QA1623 for additional information: ... index.html"

ERROR ITMS-90093: "This bundle is invalid. Apps that include arm64 architecture cannot have MinimumOSVersion set to less than '5.1.1. More information about 64-bit support for iOS is available at "64-Bit Transition Guide for Cocoa Touch" at"

Post Reply

Return to “iOS Deployment”