Trying to register chartsengine

Get help and support using chartsEngine for LiveCode.

Moderators: heatherlaine, BvG

Post Reply
Posts: 94
Joined: Fri Dec 06, 2013 3:55 am

Trying to register chartsengine

Post by tasdvl9 » Thu Feb 13, 2014 4:26 pm


I'm using an older version of Chartsengine(1.2). I need to use the newest version(1.2.1)

How do I do this?

I tried re-licensing but the older version of chartsengine is still a sub stack of my main stack file.
I tried deleting it to no avail.

When my main stack comes up it says I need to register chartsengine because the trial expired.
This is because it still sees the older version.

VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 1236
Joined: Sat Apr 08, 2006 1:10 pm
Location: Zurich

Re: Trying to register chartsengine

Post by BvG » Fri Feb 14, 2014 12:54 pm


It seems to me that you're mixing up a few things, so bear with me for this short excurse on substacks, before we get to the actual chartsEngine problem :)

A stack can be several things, so here's a short summary:
  1. Stacks are files
  2. Stacks are part of files when they're called mainstacks and substacks
  3. Each stack file has exactly one mainstack
  4. A stack file can have many substacks
  5. A mainstack and it's substacks which are an executable can't be saved
  6. Mainstacks and their substacks can also exist only in memory, without
    being within files or executables
So I guess (but of course that might be wrong) that your problem with chartsEngine is twofold: you can't get rid of a substack, and you made chartEngine a substack to begin with.

Sadly, removing a substack is kinda complicate. You need to make sure these things happen:
  1. Close the IDE, to make sure you start fresh, and open only your stack that has the wrongly attached chartsEngine.
  2. First, set the mainstack of your substack to itself. That way, it's not automatically opened together with your mainstack anymore. You can do that in the "Basic Properties" of the inspector. Make sure that in the IDE the substack (in this case chartsEngine) is actually selected. If it isn't, you might need to choose it manually with the little arrow at the top right under the lock icon. Now set the mainstack drop downof the substack to itself (it's at third place, above "controls").
  3. Now, you need to make sure the change is saved in the previous mainstack to it's stack file on disk (remember point 2 in the list above). So simply select your stack, and save it to disk. It should now not have chartsEngine as a substack anymore.
  4. Finally make sure that the chartsengine stack is gotten rid of. It is now a stack that only exist in memory (point 6 above). So simply quitting the IDE without saving that stack will make it go away forever.
  5. To check if everything went as described, reopen your project, and make sure that chartsEngine is not a substack anymore.
To avoid these problems, I suggest NOT to use chartsEngine as substack. Instead just load it in the IDE, and use it as it's own mainstack. Functionally there's no need to have a copy of chartsEngine as substack, and as you discovered, it can lead to confusing situation when you try to update or change stuff around.

Finally, when you want to use chartsEngine as part of a standalone, make sure to follow the description in the supplied documentation, and add it in the stacks pane of the "standalone application settings" of the LiveCode IDE.

Keep me up to date, especially if I miss-read your question and the problem is actually something else.
Various teststacks and stuff:

Chat with other RunRev developers: #livecode

Post Reply

Return to “chartsEngine”