Community Edition and Menus

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
rrBUSS9EE
Posts: 98
Joined: Wed May 02, 2012 3:46 pm

Community Edition and Menus

Post by rrBUSS9EE » Fri Jul 19, 2019 4:39 pm

I have a project I created several years ago with a full version of LC. It had menus, including the rather odd implementation of the "About" and "Quit" menu items in the Application menu.

The other day I tried building a standalone from it using the current stable community edition, and while the About and Quit menus show in the Application menu, it would seem they are not sending messages to my menu handlers. All other menus are working as expected.

So... do standalones built with Community edition not send messages from these menu items, or does my problem lie elsewhere?

Thanks,

Buss

bogs
Posts: 3717
Joined: Sat Feb 25, 2017 10:45 pm

Re: Community Edition and Menus

Post by bogs » Fri Jul 19, 2019 4:44 pm

I would (tentatively) say your problem lies elsewhere, without having seen the menu handlers in question. I somewhat recently put up a tutorial where I used the 'About' and 'Quit' handlers with a community edition of Lc, they worked fine there.

Have you tried tracing through the routine in the debugger at all? Set a break point at the about, for instance, and see if it is getting called.
Image

rrBUSS9EE
Posts: 98
Joined: Wed May 02, 2012 3:46 pm

Re: Community Edition and Menus

Post by rrBUSS9EE » Fri Jul 19, 2019 5:35 pm

Thanks... knowing this is not a limitation with the Community edition has allowed me to correct the issue.

bogs
Posts: 3717
Joined: Sat Feb 25, 2017 10:45 pm

Re: Community Edition and Menus

Post by bogs » Fri Jul 19, 2019 8:54 pm

Glad to hear it! Now I hope you come back and give some hint as to what the issue was, as it may help others who wind up in a similar predicament :wink:
Image

Post Reply

Return to “Mac OS”