Can't install LC 7.1dp1 on Mac OS 10.6.8

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
PaulDaMacMan
Posts: 259
Joined: Wed Apr 24, 2013 4:53 pm
Contact:

Can't install LC 7.1dp1 on Mac OS 10.6.8

Post by PaulDaMacMan » Tue Jul 28, 2015 12:36 am

Anybody else try to install LC 7.1dp1 on Mac OS 10.6.8?
It will not install for me, something about a dynlib or something?
Is this a known bug or should I file a bug report?
https://github.com/PaulMcClernan

PaulDaMacMan
Posts: 259
Joined: Wed Apr 24, 2013 4:53 pm
Contact:

Re: Can't install LC 7.1dp1 on Mac OS 10.6.8

Post by PaulDaMacMan » Tue Jul 28, 2015 1:19 am

So, I installed 7.1dp1 on a Mac running 10.9.5 and copied it over to the Mac running 10.6.8 resulting in crashing.
Looks like something related to AVFoundation:

Exception Type: EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread: 0

Dyld Error Message:
Library not loaded: /System/Library/Frameworks/AVFoundation.framework/Versions/A/AVFoundation
Referenced from: /Users/mac3/Desktop/LiveCode Community 7.1 (dp 1).app/Contents/MacOS/LiveCode-Community
Reason: image not found

Binary Images:
0x8fe00000 - 0x8fe4163b dyld 132.1 (???) <4CDE4F04-0DD6-224E-ACE5-3C06E169A801> /usr/lib/dyld
https://github.com/PaulMcClernan

Klaus
Posts: 11730
Joined: Sat Apr 08, 2006 8:41 am
Location: Germany
Contact:

Re: Can't install LC 7.1dp1 on Mac OS 10.6.8

Post by Klaus » Wed Jul 29, 2015 1:32 pm


FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7647
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Can't install LC 7.1dp1 on Mac OS 10.6.8

Post by FourthWorld » Wed Jul 29, 2015 3:11 pm

While it's good to see the LiveCode team continue to support OS X 10.6.8, Apple stopped providing security updates for that version nearly two years ago:
http://apple.slashdot.org/story/14/02/2 ... ell-anyone

For reasons not publicly explained Apple is the only major OS vendor that doesn't communicate critical end-of-life dates to their customers, so one can hardly be blamed for not knowing about this increasing vulnerability risk. Microsoft commonly provides EOL dates at least half a decade in advance, and Ubuntu provides them even before a given version is released.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

Post Reply

Return to “Mac OS”