What LiveCode version works with OSX 10.5.8?

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
80/20
Posts: 5
Joined: Mon Feb 02, 2015 5:22 am

What LiveCode version works with OSX 10.5.8?

Post by 80/20 » Tue Apr 07, 2015 11:27 pm

I have an older MacBook Air that won't update past 10.5.8, but I'd like to take it traveling and use a version of LiveCode community. Anyone know what the most up to date version of LC works on this older os? (LC7 indicates 10.6 & up, but I couldn't fine anything info on the downloads page)

Thank you in advance..!

dunbarx
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6518
Joined: Wed May 06, 2009 2:28 pm
Location: New York, NY

Re: What LiveCode version works with OSX 10.5.8?

Post by dunbarx » Wed Apr 08, 2015 3:04 am

Hi.

V. 6.x will run on 10.5.

Craig Newman

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 7427
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: What LiveCode version works with OSX 10.5.8?

Post by FourthWorld » Wed Apr 08, 2015 4:01 am

May need to go one more back - the Release Notes for v6.7 say:

The Mac engine supports:
10.6.x
10.7.x
10.8.x
10.9.x

That said, all OS X versions prior to 10.7 are increasingly risky to use, as Apple has quietly stopped providing critical security patches for them.

One option for getting a longer lifespan out a good Mac may be to consider installing Ubuntu on it. Safe, efficient, and Ubuntu 14.04 will be receiving updates regularly until April 2019 - after which you can just upgrade again because it's free and open. :)

LiveCode 7 runs quite well under Ubuntu.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

80/20
Posts: 5
Joined: Mon Feb 02, 2015 5:22 am

Re: What LiveCode version works with OSX 10.5.8?

Post by 80/20 » Wed Apr 08, 2015 3:36 pm

Thank you Craig and Richard..!

PaulDaMacMan
Posts: 241
Joined: Wed Apr 24, 2013 4:53 pm
Contact:

Re: What LiveCode version works with OSX 10.5.8?

Post by PaulDaMacMan » Tue May 19, 2015 7:47 pm

You should be able to install Mac OS X 10.6.x on any intel based Mac (probably even 10.7.x too but you may need a CoreDuo fix or something). There are a few (mostly obscure) reasons to not want to update past 10.5.8 like no Classic AppleTalk networking, no HFS support (ancient HFS not HFS+), but if you don't need to support really old Macs I don't see why you wouldn't.
As mentioned you should probably shoot for at least 10.7.x for security reasons though at least some of the security flaws in 10.6.x (BASH) have community created fixes that can be applied (usually manually via terminal command-line). Some people still have PowerPC code that they need to run and 10.6 is the last version that supports that (though built-in PowerPC-to-Intel through code translator "Rosetta").
https://github.com/PaulMcClernan

PaulDaMacMan
Posts: 241
Joined: Wed Apr 24, 2013 4:53 pm
Contact:

Re: What LiveCode version works with OSX 10.5.8?

Post by PaulDaMacMan » Tue May 19, 2015 8:02 pm

Looked it up on EveryMac.com and even the oldest MacBook Air can go up to 10.7.x
http://www.everymac.com/systems/apple/m ... specs.html
https://github.com/PaulMcClernan

richmond62
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 4146
Joined: Fri Feb 19, 2010 10:17 am
Location: Bulgaria

Re: What LiveCode version works with OSX 10.5.8?

Post by richmond62 » Wed May 20, 2015 8:48 am

If it is any comfort to you, I use 6.6 on a G5 iMac (PPC) running 10.5.8 without
any problems at all except the icon doesn't appear in the dock.

Post Reply

Return to “Mac OS”