Card replay speed: Version 6.7 and newer

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
thehat
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 31
Joined: Mon Apr 16, 2007 5:32 am
Location: Valencia, California USA
Contact:

Card replay speed: Version 6.7 and newer

Post by thehat » Mon Oct 27, 2014 5:35 pm

Stable versions of LC up to and not including 6.7 shows a flash when I click on a button that has a custom graphic using the icon and hovericon state in Yosemite. The flash was not present in Maverick. Using Yosemite I use a script that allows me to play cards and different groups of cards at varying speeds.
This script works fine in Yosemite (except for the white flash) in versions prior to stable 6.7 ( 6.7 is the version in which there is no white flash when clicking custom buttons). The speed of the card "play back" in 6.7 and 7.0 is painfully slow. What has been changed in version 6.7?

Thanks in advance for your assistance.


on mouseUp
local tstack
local tcds
local tspeed
local tnum
local tnew

set the lockmessages to true
put fld "stackname" into tstack
put the number of cards of stack tstack into tcds
put fld "speed" into tspeed
put fld "tymes" into tnum
open stack tstack
go to card 1
put tcds -1 into tnew
lock messages
repeat tnum times
repeat tnew times
wait tspeed milliseconds
go next
end repeat
wait 1 sec
go to card 1
wait 1 sec
end repeat
end mouseUp

thehat
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 31
Joined: Mon Apr 16, 2007 5:32 am
Location: Valencia, California USA
Contact:

Re: Card replay speed: Version 6.7 and newer

Post by thehat » Tue Oct 28, 2014 4:52 pm

I found if I change from hover icon to hilite icon the flash disappears. However, I did appreciate the effect of the hover icon because the user knew when they entered the button.

Does anyone have an idea why the speed of card replay became so slow in 6.7 and 7?

Thanks :D

[-hh]
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2262
Joined: Thu Feb 28, 2013 11:52 pm
Location: Göttingen, DE

Re: Card replay speed: Version 6.7 and newer

Post by [-hh] » Fri Oct 31, 2014 6:22 am

This is presumably the new graphics engine, the price we have to pay for all that new stuff.

The slow down is by a factor of up to 20 (in words: twenty). I have it not only from a card replay but from each and every graphic display.
For example some displays of large polygons are even SLOWER on Mac mini (2.5 GHz, Intel HD 4000) with LC 7.0.0 than on Raspberry Pi (800 MHz) with LC 6.5.1.
shiftLock happens

ekek
Posts: 51
Joined: Fri Sep 21, 2012 9:33 am

Re: Card replay speed: Version 6.7 and newer

Post by ekek » Fri Oct 31, 2014 5:57 pm

I also see the slowing when an iOS app opens a new card.

The same code in 6.6.4 works very fast but in Livecode 6.7 my app "freezes" every time it opens a new card.

Does someone knows what to do?

[-hh]
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2262
Joined: Thu Feb 28, 2013 11:52 pm
Location: Göttingen, DE

Re: Card replay speed: Version 6.7 and newer

Post by [-hh] » Fri Oct 31, 2014 6:45 pm

I always have a slowdown, but never had a "freeze" (or are you too impatient?).
Your's sounds like a bug. Perhaps you better report this at http://quality.runrev.com with a demo stack?
shiftLock happens

ekek
Posts: 51
Joined: Fri Sep 21, 2012 9:33 am

Re: Card replay speed: Version 6.7 and newer

Post by ekek » Fri Oct 31, 2014 8:17 pm

I'm worried not for me but for the users. They are the impatient ones :(

Let's check the bug list.

Post Reply

Return to “Mac OS”