CPU usgae

Deploying to Mac OS? Ask Mac OS specific questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
dalkin
Posts: 125
Joined: Wed Jul 04, 2007 2:32 am
Location: Blackheath, Australia
Contact:

CPU usgae

Post by dalkin » Mon Jul 12, 2021 4:07 am

I have just upgraded to LC 9.6.3 (rc1) on the following system
Screen Shot 2021-07-12 at 12.18.04 pm.png
but when I open a project and run it, the CPU goes nuts and everything slows to a crawl.
Screen Shot 2021-07-12 at 12.12.30 pm.png
This seems to be an ongoing issue (LC+BigSur) .. unfortunately, development slows to a crawl but I don't know whether it's a bug in my stack files or a bug in LC. Any suggestions? I'm happy to make the project file available to anyone who wants to test it locally.
If you're skating on thin ice you might as well dance.

richmond62
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 5893
Joined: Fri Feb 19, 2010 10:17 am
Location: Bulgaria

Re: CPU usgae

Post by richmond62 » Mon Jul 12, 2021 6:40 am

MacOS 11 and LiveCode do NOT sit well together at all.

Having upgraded to MacOS 12 beta 2 everything seems to be as it should.

dalkin
Posts: 125
Joined: Wed Jul 04, 2007 2:32 am
Location: Blackheath, Australia
Contact:

Re: CPU usgae

Post by dalkin » Tue Jul 13, 2021 2:19 am

Thanks. I suspected it was something of a terminally ill nature. I guess that means that any 'for sale' Mac apps should be labelled with a "do not use on MacOS Big Sur". The compiled app I have developed runs like a dog.
If you're skating on thin ice you might as well dance.

Bernard
Posts: 308
Joined: Sat Apr 08, 2006 10:14 pm
Location: London, England

Re: CPU usgae

Post by Bernard » Thu Jul 22, 2021 6:56 pm

This is not the case on Big Sur/M1.

LC is generally running at 2% to 9% of CPU. The only time I saw it go as high as 30% was when I was searching through all the scripts that make up the development environment.

Post Reply

Return to “Mac OS”