Apache WAMP Server and testing with "test.lc" ... Not found

Are you using LiveCode to create server scripts or CGIs?

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
JereMiami
Posts: 43
Joined: Mon Nov 03, 2014 12:17 am

Apache WAMP Server and testing with "test.lc" ... Not found

Post by JereMiami » Mon Dec 08, 2014 2:10 am

I give up! I've spent some time with this lesson: "How do I install LiveCode Server on Windows with Apache?"

According to the lesson, (I think) I should put "livecode-community-server" here: "C:/wamp/bin/apache/apache2.2.21/cgi-bin/livecode-community-server.exe"

According to the lesson, (I think) I should replace the specified code with the following code: "C:/wamp/bin/apache/apache2.2.21/htdocs"

Code: Select all

<Directory "C:/wamp/bin/apache/apache2.2.21/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    AddHandler livecode-script .lc
    Action livecode-script /livecode-cgi/livecode-community-server.exe
</Directory>

<Directory "C:/wamp/bin/apache/apache2.2.21/cgi-bin">
    Options ExecCGI
    Order allow,deny
    Allow from all
</Directory>

ScriptAlias /livecode-cgi/livecode-community-server.exe "C:/wamp/bin/apache/apache2.2.21/cgi-bin/livecode-community-server.exe"
I put the following code into notepad and save it as "test.lc" here: "C:/wamp/www"

Code: Select all

<html>

<head>
    <title>My LiveCode Server Test Page</title>
</head>

<body>
    <h1>My LiveCode Server Test Page</h1>
<?lc
     put "<p>Hello World! from LiveCode Server</p>"
    put "<p>The date is" && the date & "</p>"
?>
</body>

</html>
...and I get this when I go to localhost/test.lc: "Not Found. The requested URL /test.lc was not found on this server."

EEEK! What am I doing wrong?

JereMiami
Posts: 43
Joined: Mon Nov 03, 2014 12:17 am

Re: Apache WAMP Server and testing with "test.lc" ... Not fo

Post by JereMiami » Wed Dec 10, 2014 9:59 pm

Okay. Fixed this myself using an older version of Livecode Community Server and I switched to MAMP (for pc). The following works for me:

Step 1) Put Livecode Community Server 6.7 (drivers, externals, and livecode-community-server) here: C:MAMP/cgi-bin
** newer versions of livecode community server did not work for me
Step 2) Navigate to here: C:/MAMP/conf/apache/httpd.conf
Step 3) Replace this:

Code: Select all

<Directory "C:/MAMP ... ">
    #
    # Possible values for the Options directive are "None", "All",
    # or any combination of:
    # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
    #
    # Note that "MultiViews" must be named *explicitly* --- "Options All"
    # doesn't give it to you.
    #
    # The Options directive is both complicated and important. Please see
    # http://httpd.apache.org/docs/2.2/mod/core.html#options
    # for more information.
    #
     Options Indexes FollowSymLinks

    #
    # AllowOverride controls what directives may be placed in .htaccess files.
    # It can be "All", "None", or any combination of the keywords:
    # Options FileInfo AuthConfig Limit
    #
     AllowOverride None

    #
    # Controls who can get stuff from this server.
    #
    Order allow,deny
    Allow from all

</Directory>
With this:

Code: Select all

<Directory "C:/mamp/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
    AddHandler livecode-script .lc
    Action livecode-script /livecode-cgi/livecode-community-server.exe
</Directory>

<Directory "C:/mamp/cgi-bin">
    Options ExecCGI
    Order allow,deny
    Allow from all
</Directory>

ScriptAlias /livecode-cgi/livecode-community-server.exe "C:/mamp/cgi-bin/livecode-community-server.exe"
Step 4) Restart the server

Post Reply

Return to “CGIs and the Server”