installing LiveCode Server on Mamp

Are you using LiveCode to create server scripts or CGIs?

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
dave.kilroy
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 858
Joined: Wed Jun 24, 2009 1:17 pm
Location: Plymouth, UK
Contact:

installing LiveCode Server on Mamp

Post by dave.kilroy » Sun Apr 20, 2014 6:24 pm

Hi all

I've pored over previous postings on the forum (such as http://forums.runrev.com/viewtopic.php?f=15&t=11587) as well as the use-list - but I'm stuck - and I'm hoping some server-savvy gurus out there will be able to point out what I'm doing wrong :)

I'm running Mavericks and have got Mamp and VirtualHostx installed - and between them I can see local hosts nicely.

I downloaded LC server 6.6.1 and put it in "/Applications/MAMP/cgi-bin/LiveCodeCommunityServer-6_6_1/" and added the following lines of script to the httpd.conf file at "/Applications/MAMP/conf/apache/httpd.conf"

Code: Select all

#dave directory
<Directory "/cgi-bin/LiveCodeCommunityServer-6_6_1/livecode-community-server">
    Options ExecCGI
    Order allow,deny
    Allow from all

</Directory>
#end dave directory

#dave ScriptAlias
ScriptAlias /livecode-cgi/livecode-server "/cgi-bin/LiveCodeCommunityServer-6_6_1/livecode-community-server"
#end dave ScriptAlias

#Dave's script
AddHandler livecode-script .lc
Action livecode-script /cgi-bin/LiveCodeCommunityServer-6_6_1/livecode-community-server
#end of Dave's script
When I navigate to my "myscript.lc" test file at localhost the browser gives me the file contents (as if I'm viewing the file in textedit)

Previously I was getting the following error message (when I was following this lesson blindly http://lessons.runrev.com/spaces/lesson ... th-Apache- [which is no longer up-to-date so beware]) so I guess I'm making some sort of progress:
Not Found
The requested URL /livecode-cgi/livecode-community-server
/myscript.lc was not found on this server.
Any ideas what I'm doing wrong? And/or suggestions of where I should go from here to get LC Server working locally?

Kind regards

Dave
"...this is not the code you are looking for..."

Pyrros
Posts: 9
Joined: Sun Apr 20, 2014 8:26 pm

Re: installing LiveCode Server on Mamp

Post by Pyrros » Sun Apr 20, 2014 8:39 pm

Hi Dave

I had a simliar problem getting it to run on XAMPP on my PC. It looks like the problem is that the installation differs slightly on the later versions of apache.

Here is what my directory directive ended up looking like to get everything running:

<Directory “C:/xampp/livecode”>
Options All
AllowOverride All
Require all granted
</Directory>

ScriptAlias /livecode-cgi/livecode-community-server.exe “C:/xampp/livecode/livecode-community-server.exe”

Hopefully this will help.

Kind Regards
Simon

dave.kilroy
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 858
Joined: Wed Jun 24, 2009 1:17 pm
Location: Plymouth, UK
Contact:

Re: installing LiveCode Server on Mamp

Post by dave.kilroy » Sun Apr 20, 2014 10:40 pm

Thanks Simon

I tried your suggestion (or the OS X equivalent) but no joy.

Tried lots of other combinations too and this is what I currently have in my httpd.conf file (towards the end of the file):

Code: Select all

#dave directory
<Directory "/Users/dave/Sites/">
     Options Indexes MultiViews
     AllowOverride None
     Order allow,deny
    Allow from all
     AddHandler livecode-script .lc
    Action livecode-script /livecode-cgi/livecode-server
</Directory>
#end dave directory

#dave directory
<Directory "/Applications/MAMP/cgi-bin/LiveCodeCommunityServer-6_6_1">
    Options ExecCGI
    Order allow,deny
    Allow from all

</Directory>
#end dave directory

#dave ScriptAlias
ScriptAlias /livecode-cgi/livecode-community-server "/Applications/MAMP/cgi-bin/LiveCodeCommunityServer-6_6_1/livecode-community-server"
#end dave ScriptAlias
Any suggestions gratefully received :)
"...this is not the code you are looking for..."

Pyrros
Posts: 9
Joined: Sun Apr 20, 2014 8:26 pm

Re: installing LiveCode Server on Mamp

Post by Pyrros » Mon Apr 21, 2014 8:28 pm

Hi Dave

Unfortunately not. I tried getting mamp's windows version up and running on my pc, and its refusing to load. I'll try take a look at installing in a mac tomorrow when I am back at work.

Simon

dave.kilroy
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 858
Joined: Wed Jun 24, 2009 1:17 pm
Location: Plymouth, UK
Contact:

Re: installing LiveCode Server on Mamp

Post by dave.kilroy » Mon Apr 21, 2014 10:26 pm

Thanks Simon you're a star!
"...this is not the code you are looking for..."

Post Reply

Return to “CGIs and the Server”