HTACCESS Install on shared hosting problem

Are you using LiveCode to create server scripts or CGIs?

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
DannyBUSzJNw
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 37
Joined: Wed Apr 11, 2012 1:43 pm

HTACCESS Install on shared hosting problem

Post by DannyBUSzJNw » Fri Jan 11, 2013 9:06 pm

Hi

I installed Livecode Server successfully on MAMP in my test environment. I am now trying to get it going on the production Linux shared hosting service and as I cannot have access to the Apache config/setup - I need to use the .HTACCESS option. I installed everything according to the lessons/manuals and get an error /cgi-bin/livecode-server/test.lc was not found on this server when I want to run the test HTML/LC. File permissions are 755 where needed.

Anyone had this before or have a suggestion on what I could be doing wrong?
Thanks
Danny

bangkok
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 928
Joined: Fri Aug 15, 2008 7:15 am

Re: HTACCESS Install on shared hosting problem

Post by bangkok » Sat Jan 12, 2013 12:31 am

The exact error message you get is :
Not Found
The requested URL /xxxx/xxxxxxxxxx.lc was not found on this server
If yes, then you have a path problem.

Put your lc test file at the root of your website (where index.htm file is to be found on your regular hosting service), in order to access it by just typing

DannyBUSzJNw
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 37
Joined: Wed Apr 11, 2012 1:43 pm

Re: HTACCESS Install on shared hosting problem

Post by DannyBUSzJNw » Sat Jan 12, 2013 8:30 am

Hi

Thanks for the feedback. I do have it in the same directory (public_html) as the normal index.html (which works fine). I tried moving the test.lc file up and down in the file structure and changed path names in HTACCESS and placing the test.lc file in that directory - still the same.

So I must be doing something wrong between cg-bin and .htaccess. The /cgi-bin/livecode-server part of the message is plugged in automatically by the system and the test.lc bit obviously from what I typed in the url www.mystite.xxx/test.lc which then gives me the message as above.

Still a problem for me :(

Danny

DannyBUSzJNw
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 37
Joined: Wed Apr 11, 2012 1:43 pm

Re: HTACCESS Install on shared hosting problem

Post by DannyBUSzJNw » Sat Jan 12, 2013 8:31 am

Hi

Thanks for the feedback. I do have it in the same directory (public_html) as the normal index.html (which works fine). I tried moving the test.lc file up and down in the file structure and changed path names in HTACCESS and placing the test.lc file in that directory - still the same.

So I must be doing something wrong between cg-bin and .htaccess. The /cgi-bin/livecode-server part of the message is plugged in automatically by the system and the test.lc bit obviously from what I typed in the url http://www.mystite.xxx/test.lc which then gives me the message as above.

Still a problem for me :(

Danny

bangkok
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 928
Joined: Fri Aug 15, 2008 7:15 am

Re: HTACCESS Install on shared hosting problem

Post by bangkok » Sat Jan 12, 2013 8:44 am

What is your htaccess file ? Here is one I use on a shared hosting site.

Code: Select all

Options ExecCGI FollowSymLinks
AddHandler livecode-script .lc .irev
DirectoryIndex index.irev index.lc index.html
Action livecode-script /cgi-bin/livecode-server

DannyBUSzJNw
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 37
Joined: Wed Apr 11, 2012 1:43 pm

Re: HTACCESS Install on shared hosting problem

Post by DannyBUSzJNw » Sat Jan 12, 2013 4:24 pm

Hi Bangkok

Thanks for your kind assistance- you have "DirectoryIndex index.irev index.lc index.html" which I did not have before so ...

I changed my HTACCESS file to be exactly like the one you sent and still get "The requested URL /cgi-bin/livecode-server/test.lc was not found on this server" - now I am starting to run out of ideas.

Regards
Danny

DannyBUSzJNw
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 37
Joined: Wed Apr 11, 2012 1:43 pm

Re: HTACCESS Install on shared hosting problem

Post by DannyBUSzJNw » Sat Jan 12, 2013 4:24 pm

Hi Bangkok

Thanks for your kind assistance- you have "DirectoryIndex index.irev index.lc index.html" which I did not have before so ...

I changed my HTACCESS file to be exactly like the one you sent and still get "The requested URL /cgi-bin/livecode-server/test.lc was not found on this server" - now I am starting to run out of ideas.

Regards
Danny

andyh1234
Posts: 412
Joined: Mon Aug 13, 2007 4:44 pm
Location: Sale UK / FL USA
Contact:

Re: HTACCESS Install on shared hosting problem

Post by andyh1234 » Sat Jan 12, 2013 5:04 pm

If it helps at all, my .htaccess (working) reads...

Code: Select all

Options -Indexes +ExecCGI
AddHandler livecode-script .lc
Action livecode-script /cgi-bin/livecode-server
Very similar, but I need a + before ExecCGI and dont have the followsymlinks

One thought would be perhaps your provider maps the default /cgi-bin path to another folder, have you tried putting in the whole path from the root of the server into the action path in case the livecode-sever is simply not being found at all.

sturgis
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 1682
Joined: Sat Feb 28, 2009 11:49 pm

Re: HTACCESS Install on shared hosting problem

Post by sturgis » Sat Jan 12, 2013 5:32 pm

What shared host are you using? (if you don't mind my asking) Based on the error you get, it does appear that the .lc extension is being found, so its probably the livecode-server that is not being located. Makes me wonder what might be quirky about the setup on your shared host. You said that you placed everything in the proper locations, but just to confirm, the livecode-server and its support folders are in the root of your cgi-bin folder, and you said you confirmed the permissions of 755 on the livecode-server file itself.

If this is the case, it seems that it SHOULD work. MIght be time to contact support for the host and ask.

Hmm, the only other thing I can think to ask is.. did you create your own cgi-bin folder? If so, it won't be script aliased properly, you need to make sure you use the user script aliased folder in that should have already existed. (again, i'm sure this is not the case, but something to check)

DannyBUSzJNw
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 37
Joined: Wed Apr 11, 2012 1:43 pm

Re: HTACCESS Install on shared hosting problem

Post by DannyBUSzJNw » Sun Jan 13, 2013 11:28 am

Thanks to both of you for your answers and suggestions - much appreciated. i think you may be right, livecode-server is installed in cgi-bin (in root) but the cgi-bin folder is probably not properly set-up and I will now get the hosting company (Hetzner) to look at that for me.

Thanks again
Danny

bangkok
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 928
Joined: Fri Aug 15, 2008 7:15 am

Re: HTACCESS Install on shared hosting problem

Post by bangkok » Sun Jan 13, 2013 7:10 pm

For test purpose, you could very well install Livecode server files... into your public_html directory.

That could be easier for you to make your tests, and to avoid the file path issue.

Post Reply

Return to “CGIs and the Server”