Page 1 of 1

Error in build

Posted: Tue Feb 12, 2019 7:16 pm
by adatasol
I can't get by the "next" button after importing the DDR - I've chosen my layouts and the initial layout and then his NEXT and get this error: /bin/sh: line 1: Events[1]: command not found. Screenshots enclosed.

I tried moving the file to another location and re-running the process and tried selecting fewer layouts but it still won't get past that screen.

Re: Error in build

Posted: Tue Feb 12, 2019 7:32 pm
by adatasol
Ok -
Removing some of the layouts got me further; I was able to build when I only chose three layouts. We'll see how far I get now!

Re: Error in build - STILL BROKEN

Posted: Wed Feb 13, 2019 2:41 am
by adatasol
Boy has this been fun... not.

On the one hand I really really feel for the LCFM developers for their efforts to create a "non-native" ability to export a file out of FM to LiveCode. On the other, one wonders if this is worth it considering filemaker could kill the whole thing by bringing out a native Droid product (I know I know that will NEVER happen).

The error reporting is.... maybe useful for the LiveCode developers but useless for me. Once I properly RTFM'd everything I got to a certain point, but the errors that happened along the way could have pointed me in the right direction.

Watching the process is excruciating as it tries to copy all the aspects of layouts (including it appears, elements off the active layout area).

So, I got as far as pushing up my interface file to FMS 17 and making sure the data API was enabled, and now when I hit next I get this:

[warn] kq_init: detected broken kqueue; not using.: Undefined error: 0
[[ LCFM Native ]] EXTRACT
[[ EXTRACT FILE ]] Dear_Future_Me
[[ EXTRACT TABLE ]] Responses (132)
[[ EXTRACT TABLE ]] Questions (131)
[[ EXTRACT TABLE ]] Sessions (134)
UNHANDLED ERROR: 634,0,0,could not decode JSON: unexpected token near end of file (engine)
634,0,0,could not decode JSON: unexpected token near end of file
219,28,8,mergJSONDecode
465,28,8
241,28,1,JSONToArray
353,0,0,stack "com.livecode.lcfm-native.libjson" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
219,22,9,JSONToArray
219,22,9,JSONToArray
511,22,9
241,22,1,jsonDecode
353,0,0,stack "com.livecode.lcfm-native.libjson" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
219,383,6,jsonDecode
465,383,6
241,383,1,_lcfmnativeExtractJsonRecord
353,0,0,stack "com.livecode.lcfm-native.liblcfmnative.extract" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
573,119,1,_lcfmnativeExtractJsonRecord
253,119,1
241,109,1,_lcfmnativeExtractUsingScript
353,0,0,stack "com.livecode.lcfm-native.liblcfmnative.extract" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
573,90,1,_lcfmnativeExtractUsingScript
253,90,1
490,90,1
490,90,1
241,52,1,_lcfmnativeExtractFiles
353,0,0,stack "com.livecode.lcfm-native.liblcfmnative.extract" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
241,1646,1,lcfmnativeExtractProject
353,0,0,stack "com.livecode.lcfm-native.liblcfmnative" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
241,299,1,_extract
353,0,0,stack "com.livecode.lcfm-native.cmdlcfmnative" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
573,90,1,_extract
587,90,1
241,29,1,lcfmnativeOnRun
353,0,0,stack "com.livecode.lcfm-native.cmdlcfmnative" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
675,38,1,lcfmnativeOnRun
241,38,1,_envDispatchLifecycleEvent
353,0,0,stack "com.livecode.lcfm-native._env.common" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native"
573,96,1,_envDispatchLifecycleEvent
253,96,1
stack "com.livecode.lcfm-native._env.common" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native",<protected>,0
stack "com.livecode.lcfm-native._env.common" of stack "/Applications/LCFM Native.app/Contents/MacOS/lcfm-native.app/Contents/MacOS/lcfm-native",<protected>,0

Re: Error in build

Posted: Wed Feb 13, 2019 11:19 am
by bogs
Hi adatasol,
Sorry to hear that you were having so much trouble with this. Although I know less than nothing about File Maker, and so can't tell you what is going wrong with what your doing, it is possible that you could email support and find out right away how to solve the problems your having.

They are generally very fast at responding to email, and as far as I can tell have been more than willing to field any question about their products.

Re: Error in build

Posted: Wed Feb 13, 2019 5:45 pm
by jacque
The error codes are briefly described in the "errorDialog" entry in the dictionary. Basically the first number is what you want to look up, that's the actual error code. The codes are stored in LC but it's easier to use the lookup stack we've posted to LiveCode Share.

Click the User Samples icon in the LiveCode toolbar and search for LiveCode Error Lookup. Once the stack opens you'll want to save it to disk so you have a local copy.

The errors build on each other and you have quite a long list, so look first at the top one. If you want to trace backward, work down the list. Each line triggered the error above it.

The FM product is new and I don't think this is how it should behave, so you'd do the team a favor if you'd report the problem at http://quality.livecode.com. I'm sure they want this to be easier on you.

Don't give up yet. :-)