iOS app icon only generic in LC 9.01 and 9.03

If you find an issue in LiveCode but are having difficulty pinning down a reliable recipe or want to sanity-check your findings with others, this is the place.

Please have one thread per issue, and try to summarize the issue concisely in the thread title so others can find related issues here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
Posts: 2
Joined: Tue May 07, 2019 4:18 pm

iOS app icon only generic in LC 9.01 and 9.03

Post by melly » Fri May 10, 2019 11:14 pm

I am not getting my custom iOS app file icon to show up on the phone desktop; neither on the Simulator nor when side-loaded onto the iPhone. The phone just shows the generic app icon. On the other hand, the iOS splash screen shows up just fine. My Android build has the opposite problem. The splash screen doesn't show up but the app icon is correct.

I've tried to get the iOS app icon to show up using both LC 9.01 and 9.03, with their recommended Xcode versions 9.2 and 10.1 respectively. I'm operating with MacOS 10.14 Mojave. My iPhone is 5s running the latest iOS 12.2 (forced by Apple to update).

The iPhone 5s splash screen shows up OK before the app loads. The iOS app is very simple, with just one iOS native button (no code attached), one SVG (smiley face), and one standard LC text field with nothing in it.

Although the Android splash screen fails to show up the custom app icon is displayed well. Whatever components I pile into the Android stack (I used 7 cards, with buttons, fields, images, SVG, and lots of code, a tree, and do file work in/out of dataGrid tables); the Android app "just works". I'd like to take that app and convert it to the iPhone but don't want to do so with only a generic app icon to display.

I loaded all the proper icons in the iOS standalone settings—except for any iPad icons. I've tried different icons just to be sure they aren't corrupt. I've also loaded the app onto the iPhone via Xcode and via iMazing (which side-loads iOS apps easier than Xcode). Nonetheless, the iOS app still shows only the generic icon. Curiously though, iMazing shows the intended app icon image in its panel display of all apps it finds on the phone! This tells me the designated custom icon is bundled with the iOS app but the phone is unable to display the image. I thought maybe a power down and up would fix the anomaly. I tried that twice to no avail.

In previous apps I've built using LC 6,7, and 8, I had no problem displaying the app icons. Is this a bug in the latest 9.* LC ? I sure hope this is a user error on my part, because It would be impractical for me to downgrade my MacOS and my iPhone iOS as well as LC, without a whole lot of time and trouble.
MacOS 10.14 Mojave, Windows OS 10, iOS 12.2, iPhone 5s and 6s, Android 7.0. Also programming in C and Java, and several other languages.

Livecode Staff Member
Livecode Staff Member
Posts: 686
Joined: Fri Feb 06, 2015 4:03 pm

Re: iOS app icon only generic in LC 9.01 and 9.03

Post by LiveCode_Panos » Sun May 12, 2019 3:19 pm

Hello melly,

Could you post here the iOS icons you use and don't appear?

There might be an issue in the icon files.

RE Android and the splash screen not showing, note the Android splash screen is not supported on Indy and Business editions (the icon chooser should be disabled - see


Post Reply

Return to “Bug Triage”