hide cursor during video problem -- please help

Visuals, audio, animation. Blended, not stirred. If LiveCode is part of your rich media production toolbox, this is the forum for you.

Moderators: FourthWorld, heatherlaine, Klaus, kevinmiller, robinmiller

Post Reply
rfarnold47
Posts: 6
Joined: Sun Jan 05, 2020 5:32 am

hide cursor during video problem -- please help

Post by rfarnold47 » Thu Jun 27, 2024 4:34 am

Hello and thanks up front for any help here.

I have created an app to display a video artwork full screen -- it randomly sequences video clips.

All is good but there are two presentation modes, one manual and the other automatic.

All video is played by clicking the "play" button I created that is scripted to select and play the videos full screen, with a hidden and locked cursor.

When it is played manuially by clicking the "play" button, it works just fine, cursor is hidden (set cursor to none; lock cursor).

However, if the button is triggered in the OpenStack script based on stored preference setting to play automatically, that sends "mouseup" to the "play" button (on card 1 of the stack) everything works as it should except the cursor is not hidden.

I assume this may be due to messages. In the manual class (click the Play" button on card 1, the stack is fully opened and the card is fully opened. Perhaps something isn't the same is the button is clicked with a "send mouseup" command from the openstack script, but I have not been able to figure out.

Again, the "set cursor to none; lock cursor" commands are in the video play script in the "Play"button and it works if the button is manually clicked, but not (just the cursor; everything else works as expected) when the mouseup is sent to the play button from the openstack command.

Any ideas why this happens, and how I might try to fix it?

Right now I am moving the mouse to the bottom right corner of the screen and asking those who show the project to cover that corner with a small piece of black tape (since it is in the piller-boxing of the 4:3 video on a 16:9. monitor -- but this is hardly an ideal solution.

Thanks again!

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 9917
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: hide cursor during video problem -- please help

Post by FourthWorld » Thu Jun 27, 2024 6:57 am

What happens if you add "wait 100 millisecs with messages" just before the line that sends "mouseUp" to the button?
Richard Gaskin
LiveCode development, training, and consulting services: Fourth World Systems
LiveCode Group on Facebook
LiveCode Group on LinkedIn

SparkOut
Posts: 2872
Joined: Sun Sep 23, 2007 4:58 pm

Re: hide cursor during video problem -- please help

Post by SparkOut » Thu Jun 27, 2024 7:48 am

Richard's suggestion is good, very good, and hopefully will solve the problem.
If it doesn't, I would suggest you keep the wait with messages, but also I am intrigued to know how you are kicking the routine off and whether you have all the code for the display inside the mouseUp handler, including the lock cursor statement.
Try taking all that code along with the lock cursor, and put it into a new handler in the stack script, called whatever you like, such as displayTheArt.
Then in the openStack script, do not "send mouseUp" but instead at that point just have the statement displayTheArt.
In the mouseUp handler just have

Code: Select all

on mouseUp
   displayTheArt
end mouseUp

Post Reply

Return to “Multimedia”