Search found 15 matches

by AlbertAA
Sun Oct 18, 2020 12:37 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Making an app stop automatically if user is not active
Replies: 8
Views: 1134

Re: Making an app stop automatically if user is not active

Thanks a lot for the suggestions. I first tried implementing Craig's suggestion, with some adaptations for things like dialogs remaining open/unanswered and things like the user "forgetting" the app and start typing on a different app/window. If finally kind of worked, but was leaving me with a feel...
by AlbertAA
Thu Oct 08, 2020 5:35 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Making an app stop automatically if user is not active
Replies: 8
Views: 1134

Making an app stop automatically if user is not active

Hello. Our users are running our apps (educational games) in a browser via a Virtual Machine. We had to move to this solution because (1) in some cases users do not want go through the "trouble" of installing an app on their PCs or Macs (which are often "locked" by their companies anyway). and (2) b...
by AlbertAA
Tue Aug 18, 2020 3:28 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Strict compilation mode
Replies: 4
Views: 865

Re: Strict compilation mode

Not having to declare local variables explicitly is one of the many features/bugs or strengths/weaknesses of LiveCode.
I advise to remove the "//" (which caused all your problems), and also to remove the "local tAdd" (which you do not need).
Best luck
by AlbertAA
Sun Aug 16, 2020 11:31 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6
Replies: 12
Views: 1500

Re: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6

Yes! Imagine that a few pieces are untouched from original 1995 HyperCard stacks :) What a journey!
Thank you again Klaus for the "magic trick" which now allows me to edit even my "old/dusty/dirty" stack properly also with 9.6 :)
by AlbertAA
Sun Aug 16, 2020 4:21 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6
Replies: 12
Views: 1500

Re: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6

Thank you for the suggestion. I just emailed it to you.
Btw I tried opening the stack also on the Mac (version 9.6) and I have the same problems of "limited editability of objects".
by AlbertAA
Sun Aug 16, 2020 3:39 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6
Replies: 12
Views: 1500

Re: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6

Yes. As soon as I open the stack with 9.6 even new buttons and fields behave in this "limited" way. I noticed that when I select objects I cannot "copy" them. The Project Browser also behaves in a limited way (not possible to click to open the properties), etc... While the same stack, in 5.0.2 behav...
by AlbertAA
Sun Aug 16, 2020 1:12 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6
Replies: 12
Views: 1500

Re: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6

... actually the Properties of the Buttons are limited too, compared to the usual properties I get for buttons in 9.6. Some of the info that were there in 5.0.2 seem really to get lost when I open the stack in 9.6.
by AlbertAA
Sun Aug 16, 2020 1:09 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6
Replies: 12
Views: 1500

Missing Contents Tab in Fields when moving from version 5.0.2 to 9.6

Hello. I am experiencing 2 strange behaviours when porting old stacks to 9.6 indy: I started with some old stacks in Metacard. First opened them in Rev, then moved to LiveCode 5.0.2. There everything is fine and I saved them as livecode files. The problem appears if I open the 5.0.2 stack in 9.6: In...
by AlbertAA
Tue Jun 30, 2020 9:29 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: A stack on the web which accepts parameters
Replies: 7
Views: 1388

Re: A stack on the web which accepts parameters + ftp upload from LC script on LC Server

The LC Server and the FTP server are on different machines, unfortunately (as I did not succeed in installing Apache and LC Server correctly on the sme machine, which runs ISS). Your script was inspiring. Thank you. After trying for some time to adapt it to go through shell commands, I decided to sw...
by AlbertAA
Tue Jun 30, 2020 3:09 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: A stack on the web which accepts parameters
Replies: 7
Views: 1388

Re: A stack on the web which accepts parameters

Following your advice I adventured into setting up an Apache server and learning to work with the LC Server. It is definitely a good solution to be able to do exactly what I wanted originally : To call what is now a LC script (rather than a stack) the way I needed - from a URL with parameters. Every...
by AlbertAA
Mon Jun 22, 2020 7:28 am
Forum: Getting Started with LiveCode - Complete Beginners
Topic: A stack on the web which accepts parameters
Replies: 7
Views: 1388

Re: A stack on the web which accepts parameters

You are perfectly right. I was just hoping not to have to dive into server issues, but this is effectively a task that should be done from there (no UI needed). I will go through your links and hope to find out there if what I need to do can be done easily with a LC server. Still interested in findi...
by AlbertAA
Sun Jun 21, 2020 7:56 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: A stack on the web which accepts parameters
Replies: 7
Views: 1388

A stack on the web which accepts parameters

I have another beginner question, related to using LC to create stacks which run on the web (which I have never done until now). I checked out the LiveCode Lesson on creating a standalone stacks which can be accessed from the Web, but also realized that in order to be able to try it I need to acquir...
by AlbertAA
Sun Jun 21, 2020 6:55 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Standalone through Remote Desktop access and VMs
Replies: 4
Views: 1756

Re: Standalone through Remote Desktop access and VMs

Thanks a lot. Very useful hints. > In the meantime I have followed your advice, got a new license and moved from Rev 2 point 6 to LC 9. > Currently I am still testing if the display is different in the case I copy/paste the pictures directly (currently I specify image sources). If copy/pasting the p...
by AlbertAA
Fri May 29, 2020 12:52 pm
Forum: Getting Started with LiveCode - Complete Beginners
Topic: Standalone through Remote Desktop access and VMs
Replies: 4
Views: 1756

Standalone through Remote Desktop access and VMs

I am experiencing a problem with the display of images when accessing my standalone/exe via Remote Desktop Connection (or one of MS Azure Virtual Machines). Images that normally display well are not visible anymore when I start the exe on the server and see it via Remote Desktop. If I set the qualit...
by AlbertAA
Fri May 29, 2020 12:50 pm
Forum: Off-Topic
Topic: Limitations on posting images and links
Replies: 2
Views: 1520

Limitations on posting images and links

Sorry to intervene here, but I a have an issue too and perhaps you can help me. I am a new user and wanted to send a post in "Off Topic" (that you moderate too). I tried to submit a post writing text only but I got the error message "You can’t post image, email or url links that are external to this...

Go to advanced search