Search found 17 matches

by LeProfBard
Thu Jun 04, 2020 5:42 pm
Forum: HTML5
Topic: Back to accented characters & HTML5
Replies: 4
Views: 1208

Re: Back to accented characters & HTML5

Thank you, Jacque.
That's worth a try. I also stumbled across an older bug report on a similar issue that was resolved by pointing out that the 'fixed line height' cannot be left as 'false'. I will try that later today, to see if it takes care of it.
by LeProfBard
Wed Jun 03, 2020 4:20 pm
Forum: HTML5
Topic: Back to accented characters & HTML5
Replies: 4
Views: 1208

Re: Back to accented characters & HTML5

Thank you for this excellent follow up. It helps to have some confirmation, even if it doesn't bring a solution yet. I'll keep asking!
by LeProfBard
Tue Jun 02, 2020 7:16 pm
Forum: HTML5
Topic: Back to accented characters & HTML5
Replies: 4
Views: 1208

Back to accented characters & HTML5

Hi, Having a baffling problem with accented characters--no, actually, with just one character: ñ . In other words, 'mañana' never comes. In my web app, this character appears numerous times, along with many other accented characters. In the IDE, it's perfect; when I save as a standalone, all the oth...
by LeProfBard
Mon May 04, 2020 6:58 pm
Forum: HTML5
Topic: Delete key failing in html standalone?
Replies: 3
Views: 2277

Re: Delete key failing in html standalone?

To provide some additional information, the Delete key works perfectly in Safari (Mac), but fails on every other browser.
by LeProfBard
Sat May 02, 2020 1:37 pm
Forum: HTML5
Topic: Delete key failing in html standalone?
Replies: 3
Views: 2277

Delete key failing in html standalone?

Hi,
I have several text fields that capture user input, but when saved as a standalone, the delete/backspace key (Mac) is non-functional. I've tried this in Chrome and in Firefox and will be testing it on other OS and browsers, but I need to fix this. Any suggestions?
by LeProfBard
Mon Apr 27, 2020 2:53 am
Forum: HTML5
Topic: html5 POST fails... why?
Replies: 1
Views: 952

Re: html5 POST fails... why?

Never got the POST version to work, but a version with GET does work: on mouseUp put URLencode("Spanish") into tArray["tLang"] put URLencode("Typhoid Mary") into tArray["tStudentName"] put "?tLang=" & tArray["tLang"] & "&tStudentName=" & tArray["tStudentName"] into tDataToSend Get URL ("https://.......
by LeProfBard
Mon Apr 27, 2020 1:17 am
Forum: HTML5
Topic: html5 POST fails... why?
Replies: 1
Views: 952

html5 POST fails... why?

Hi, THis is driving me nuts, but it's gotta be something simple.... the LC script below works perfectly when triggered in the run mode of the IDE on the desktop..., but when the same simple file is saved as HTML, nothing makes it through to the server. Can someone suggest what is going on? on mouseU...
by LeProfBard
Thu Apr 23, 2020 5:38 pm
Forum: HTML5
Topic: Transfer to/ from html5 standalone and text file
Replies: 15
Views: 3263

Re: Transfer to/ from html5 standalone and text file

oh, BTW, I ended up using tsNetPost with callbacks, as per :
http://lessons.livecode.com/m/4071/l/69 ... -callbacks

L P B
by LeProfBard
Thu Apr 23, 2020 5:35 pm
Forum: HTML5
Topic: Transfer to/ from html5 standalone and text file
Replies: 15
Views: 3263

Re: Transfer to/ from html5 standalone and text file

Hi Wally, Sure. Here's what worked for me in PHP. I'm still hacking away on finding the LC equivalents, though. <?php $chiffre = ($_POST["nextNumber"]) ."\n"; //receives new number, adds CR $file = 'numbers.txt'; file_put_contents($file, $chiffre, FILE_APPEND | LOCK_EX); // Appends, locks file from ...
by LeProfBard
Thu Apr 23, 2020 4:18 pm
Forum: HTML5
Topic: Transfer to/ from html5 standalone and text file
Replies: 15
Views: 3263

Re: Transfer to/ from html5 standalone and text file

Hi Richard,
Thanks for asking your question, it pointed me in the right direction. I was first able to set up the 'write to text file' via PHP, but I'm pursuing it in .lc, just not quite there.
Thanks to all for your responses.
by LeProfBard
Mon Apr 20, 2020 3:16 am
Forum: HTML5
Topic: Transfer to/ from html5 standalone and text file
Replies: 15
Views: 3263

Re: Transfer to/ from html5 standalone and text file

Hi Klaus (and FourthWorld--I've read and appreciated comments from both of you in many of the forums over the years, too) No progress: the script apparently ran, but nothing was delivered to the text file, and there was no error code returned. FourthWorld: you asked earlier 'what's on the server to ...
by LeProfBard
Sun Apr 19, 2020 6:03 pm
Forum: HTML5
Topic: Transfer to/ from html5 standalone and text file
Replies: 15
Views: 3263

Re: Transfer to/ from html5 standalone and text file

Yes, it's on the server, not on the client/user's file system.
Thanks,
L P B
by LeProfBard
Sun Apr 19, 2020 5:06 pm
Forum: HTML5
Topic: Transfer to/ from html5 standalone and text file
Replies: 15
Views: 3263

Transfer to/ from html5 standalone and text file

Hi, Long time LC user, needing to move reliable stacks & projects to web apps (thanks, C-19!). Here are some of my travails, can someone point me in the right direction, please? I want to send the content of a variable (the output) from one stack (html5 standalone) to text file. For context, I'm usi...
by LeProfBard
Tue Apr 14, 2020 6:48 pm
Forum: CGIs and the Server
Topic: LC server, tsNetSmtpSync, mimeEncode and ignorance
Replies: 1
Views: 1692

Re: LC server, tsNetSmtpSync, mimeEncode and ignorance

Hi, If anyone is interested, here is the helpful response I got from the LC team--and it works! So it turns out that the problem with "MimeEncodeAsMimeEmail" is that it's not present by default in LiveCode Server. You need to add the MIME library to the server and start using it... so if you add the...
by LeProfBard
Fri Apr 10, 2020 5:55 pm
Forum: CGIs and the Server
Topic: LC server, tsNetSmtpSync, mimeEncode and ignorance
Replies: 1
Views: 1692

LC server, tsNetSmtpSync, mimeEncode and ignorance

Hi, I'm trying to send an email via SMTP on the LC hosting server via a simple .lc script. The script is below, but the server chokes on the "mimeEncode..." command: it doesn't know what to do with it. What am I missing? <?lc put "[correct username]" into tSettings["username"] put "[correctPW]" into...

Go to advanced search