unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable_SOLVED

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2486
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable_SOLVED

Post by jmburnod » Mon Jun 15, 2020 10:17 am

Hi All,
I try to copy my app on my iPad Air 2 with this environment:
iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable, development profile
I see in release notes:
Xcode 11.3 on MacOS 10.14 (Note: You need to upgrade to 10.14.4)

But i get an error "unable to install..." and 13.5.1 is the only version i can install from my iPad.

Thanks in advance for your lights

Best regards
Jean-Marc
Last edited by jmburnod on Wed Jul 01, 2020 9:49 am, edited 1 time in total.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 672
Joined: Fri Feb 06, 2015 4:03 pm

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by LiveCode_Panos » Mon Jun 15, 2020 5:24 pm

Hello Jean-Marc,

Could you post a screenshot of your iOS standalone settings?

Kind regards,
Panos
--

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2486
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by jmburnod » Mon Jun 15, 2020 5:32 pm

Hello Panos,
I was very glad to see it should work from LC 8.0 or later :D
TsandaloneSettingEep.png
Kind regrds
Jean-Marc

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2486
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by jmburnod » Mon Jun 15, 2020 5:42 pm

Thanks again Panos for quick message
I tested with option ios12 and 13 or later with the same result. :oops:
I can see xCode answer if I want replace existent app
Jean-Marc

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 672
Joined: Fri Feb 06, 2015 4:03 pm

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by LiveCode_Panos » Tue Jun 16, 2020 8:10 am

Hello Jean-Marc,

The settings look OK. If Xcode asks you if you want to replace existing app, it means that an app with the same identifier is already installed in the device.

I suggest changing the app id to something that definitely does not exist in the device, and try again.

If this does not fix the problem, could you post a screenshot of the error msg you get in Xcode?

Kin regards,
Panos
--

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2486
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by jmburnod » Tue Jun 16, 2020 9:37 am

Hello Panos,
What i get as error message
ErrorUnableInstall.png
Kind regards
Jean-Marc

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2486
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by jmburnod » Fri Jun 19, 2020 6:00 pm

Hi All,
I have to update my app before 30 june with xCode11 but i get always the same error.
All works fine with LC 9.5.0 and xCode 10.1
Am I the onlyone to encounter this error ?
Best regards
Jean-Marc

paulw
Posts: 8
Joined: Mon Jul 25, 2016 8:41 am

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by paulw » Fri Jun 19, 2020 8:55 pm

Jean-Marc,

I had a similar issue, though with a later version of Xcode (11.4) - everything ran fine on the simulator and LC compiled everything to a standalone version but I couldn't install to an actual device. The problem turned out to be the profile I'd generated (and had selected on the standalone settings) had expired. It might be worth checking/updating them.

Regards,
Paul

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2486
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by jmburnod » Sat Jun 20, 2020 2:55 pm

Hi Paul,
Thanks for your message.I feel me less alone
I checked certificates and profile and all seem OK.
Best regards
Jean-Marc

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 672
Joined: Fri Feb 06, 2015 4:03 pm

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by LiveCode_Panos » Sun Jun 21, 2020 10:56 am

Hello Jean-Marc,

Is that a new device? Could it be the case the device UUID is not registered in the Apple Dev website? Or maybe it is registered, but it is not included in the list of supported devices for this particular provisioning profile you are using?

Kind regards,
Panos
--

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2486
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by jmburnod » Sun Jun 21, 2020 6:52 pm

Hello Panos,
That is not a new device and I can install me app from an other Mac with LC 9.5.0 and xCode 10.1
Yes this device is included in the list of device.
I get a new comment in xCode "missing private key"
Curiosly, i get the same comment on my other Mac with LC 9.5.0 and xCode 10.1 but I can install my app without problem.

I see that I can define one private key on my apple account but I need some explanations about it before I jump in a new swimming pool.

I just get a message in stackoverflow.com
https://stackoverflow.com/questions/471 ... rivate-key

I'll study it and write back once i'm able to understand what is it

Of course, advices are welcome

Kind regards

Jean-Marc

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2486
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: unable to install...iOS 13.1.2, xCode 11.3.1, OS X 10.14.6, LC 9.6.0 stable

Post by jmburnod » Wed Jul 01, 2020 9:48 am

Hi All,
I tried the way explaned in stackoverflow but it doesn't work for me.
I'm gone out from this probleme using a request for a new certificate in keychain and all work fine. :D
Kind regards
Jean-Marc

Post Reply

Return to “iOS Deployment”