LC 9.6 DP4 not working on iOS 10.3.3 ipad

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller, robinmiller

Post Reply
raugert
Posts: 70
Joined: Thu May 26, 2016 9:30 pm
Location: Winnipeg, Canada

LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by raugert » Sun May 10, 2020 4:55 pm

I recently updated my app on the App store using LC 9.6 DP4 and it now crashes on an iPad with iOS 10.3.3 . It still works OK on iOS 11.2.6

Also, it no longer works with an iPad Provisioning profile either. Is it possible that LC 9.6 will no longer support older iOS versions ?

Has anyone else noticed this ?

thanks,
Richard

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 695
Joined: Fri Feb 06, 2015 4:03 pm

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by LiveCode_Panos » Mon May 11, 2020 8:29 pm

Hello Richard,

Does your app include a browser widget, or a mobile browser control? If so, it will not work on iOS 10.
This does not affect LC 9.5.1.

Kind regards,
Panos
--

raugert
Posts: 70
Joined: Thu May 26, 2016 9:30 pm
Location: Winnipeg, Canada

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by raugert » Mon May 11, 2020 8:40 pm

Thanks for the reply Panos

My app does not use a browser widget nor a mobile browser control as such. It does however use tsNet to send commands to a device that it is controlling (vMix Video Switcher). It uses a browser API to do that. I don't know if that has anything to do with it ?

thanks for your expertise,
Richard

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 695
Joined: Fri Feb 06, 2015 4:03 pm

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by LiveCode_Panos » Mon May 11, 2020 8:50 pm

Hello Richard,

Hmm, TBH I do not have an iOS 10 device so it is difficult to test, but a couple of users that have reported crashes on iOS 10 with LC 9.6-x, they all had a browser widget or a mobile browser in their apps.

In LC 9.6 these controls use a WKWebView instead of a UIWebView (as Apple requires this now), so I assumed the problem was because of a bug or incompatibility of our WKWebView implementation.

If you have an iOS 10 device at hand, it might be worth checking building the app without the "tsNet" and "Internet" inclusions and see if it still crashes on startup.

Kind regards,
Panos
--

raugert
Posts: 70
Joined: Thu May 26, 2016 9:30 pm
Location: Winnipeg, Canada

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by raugert » Mon May 11, 2020 10:15 pm

Hi Panos,

I tested on iPad iOS 10.3.3 with LC9.6 RC1.

If I select either "tsNet" or "internet" in the inclusions, it crashes on startup.

thanks Panos,
Richard

raugert
Posts: 70
Joined: Thu May 26, 2016 9:30 pm
Location: Winnipeg, Canada

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by raugert » Sat May 23, 2020 2:11 pm

I noticed that this was not yet fixed in LC 9.6 RC2. App is still crashing on iOS 10. Should I submit a bug report somewhere ?

jessamy99
Posts: 103
Joined: Thu Oct 25, 2012 3:23 pm

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by jessamy99 » Thu Aug 06, 2020 5:42 pm

Hi everyone,

I am also having a problem with iOS 10.3.3 on an iPad.

I build an App using LC 9.6.0 and Xcode 11.3.
In the settings I choose iOS 10

It appears to include iOS 10 and on, but when I downloaded it from the store, it crashed on opening.

Any suggestions would be gratefully received.

Best wishes everyone, I do hope you are all keeping well and safe!!
Jessamy

PS I am on a Mac with Mojave.

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2542
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by jmburnod » Thu Aug 06, 2020 6:01 pm

Hi All
I have an app (LC 9.6, xCode 11.3, Mojave)
No widget no tsNet
It works fine on an iPad 10.3
Best regards
Jean-Marc

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 695
Joined: Fri Feb 06, 2015 4:03 pm

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by LiveCode_Panos » Thu Aug 06, 2020 6:05 pm

Hello all,

This bug should be fixed in LC 9.6.1 rc-2.

Kind regards,
Panos
--

jessamy99
Posts: 103
Joined: Thu Oct 25, 2012 3:23 pm

Re: LC 9.6 DP4 not working on iOS 10.3.3 ipad

Post by jessamy99 » Thu Aug 06, 2020 6:19 pm

Hi Jean-Marc,

It is not working for me :(

Hi Panos,

Thankyou, I will try that LiveCode.

Keep well everyone!!
Best wishes,
Jessamy

Post Reply

Return to “iOS Deployment”