Unable to start the simulator

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
babas66
Posts: 9
Joined: Wed May 15, 2019 11:13 am

Unable to start the simulator

Post by babas66 » Tue Oct 15, 2019 9:55 am

When I try to test an iOS app with the simulator, Livecode answer this :
"Unable to start the Simulator : Failed to install the requested app"

Has anyone ever seen this error message ?

I'm using LC 9,0,5 and Xcode 10,1. I don' t find solution to solve this error ... .

Thanks

Seb

sphere
Posts: 960
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to start the simulator

Post by sphere » Tue Oct 15, 2019 1:28 pm

Run the iOs emulator from within Xcode. Start Xcode---> run emulator
Then hit the test button again.

The it will work.
I had the same error as you, it seems it does not start the emulator from LC
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

babas66
Posts: 9
Joined: Wed May 15, 2019 11:13 am

Re: Unable to start the simulator

Post by babas66 » Tue Oct 15, 2019 2:31 pm

thanks you for the reply.

It still not working with the same error. I tried launching the simulator within Xcode with the same result. Before, I opened the simulator directly in the package of Xcode (contents > developer > Applications > Simulator) and the test with LC worked well. I have recently change my Mac and now I have this error "Unable to start the Simulator : Failed to install the requested app".

(sorry for my English)

bogs
Posts: 3995
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to start the simulator

Post by bogs » Tue Oct 15, 2019 2:40 pm

babas66 wrote:
Tue Oct 15, 2019 2:31 pm
(sorry for my English)
Don't be, although I don't have an answer to your question, your english appears to be fine.
Image

sphere
Posts: 960
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to start the simulator

Post by sphere » Tue Oct 15, 2019 4:25 pm

Indeed your english is fine.
Check in lc settings for mobile phone if xcode is found. Then check the version of xcode. The last version of xcode is not yet supported, but will be in the next lc as far as i know.
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

babas66
Posts: 9
Joined: Wed May 15, 2019 11:13 am

Re: Unable to start the simulator

Post by babas66 » Tue Oct 15, 2019 9:50 pm

Settings in livecode are ok, I have Xcode 10,1 linked and the icon is green. The release notes of LC 9,0,5 specify the compatibility with Xcode 10,1.
It is possible that the problem is about an error with the internal app ID and Profile (stand-alone settings) ?

Tomorrow I will try to do again this [how-to-create-a-free-ios-development-provisioning-profile/]configuration[/url] with Xcode

Thanks again for your help

Seb

PS off topic : is not possible to add a link in this message ? I tried to add an url (lessons of LC) but I can’t. The same thing if I want to write the number of a version including points (I have to replace them with coma in this message)

bogs
Posts: 3995
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to start the simulator

Post by bogs » Tue Oct 15, 2019 9:55 pm

babas66 wrote:
Tue Oct 15, 2019 9:50 pm
PS off topic : is not possible to add a link in this message ? I tried to add an url (lessons of LC) but I can’t. The same thing if I want to write the number of a version including points (I have to replace them with coma in this message)
PS on topic (or at least a popular question), yes it is possible to add a url, however you need a post count of 10 first. You have 7 to go (as of this post) :D
postCount.png
3 down...
postCount.png (6.86 KiB) Viewed 705 times
Image

babas66
Posts: 9
Joined: Wed May 15, 2019 11:13 am

Re: Unable to start the simulator

Post by babas66 » Tue Oct 15, 2019 10:03 pm

bogs wrote:
Tue Oct 15, 2019 9:55 pm
PS on topic (or at least a popular question), yes it is possible to add a url, however you need a post count of 10 first. You have 7 to go (as of this post) :D
Oh! Ok, sorry :D . I think it’s very possible that I continue to post in this forum, seem very helpful... and I’m a beginner with LC! :roll:

sphere
Posts: 960
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Unable to start the simulator

Post by sphere » Tue Oct 15, 2019 10:16 pm

Tomorrow I will try to do again this [how-to-create-a-free-ios-development-provisioning-profile/]configuration[/url] with Xcode
i'm not 100% sure, but it could be the cause indeed that it is not installing due to a wrong provisioning profile.
But if you already had one before, then it might be enough to repair/restore it when opening the project in Xcode(if you had one already made for that app on your previous system as you wrote), else do the lesson to refresh it
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

bogs
Posts: 3995
Joined: Sat Feb 25, 2017 10:45 pm

Re: Unable to start the simulator

Post by bogs » Tue Oct 15, 2019 10:17 pm

We hope you enjoy our little place here :D

I would add that, without exception, everyone was once a beginner in Lc (although several had a HUGE jumpstart having used Hc and Mc), so your in good company, and no apologies are necessary :wink:
Image

babas66
Posts: 9
Joined: Wed May 15, 2019 11:13 am

Re: Unable to start the simulator

Post by babas66 » Wed Oct 16, 2019 1:19 pm

Hello,

I tried to reconfigure all the settings of Xcode and I can install an app in a physical device now. The simulator still not working with the same error but at least I can test an app in iOS again !

Thanks for yours replies.

If I find a solution for the simulator (I hope), I will say it here.

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 590
Joined: Fri Feb 06, 2015 4:03 pm

Re: Unable to start the simulator

Post by LiveCode_Panos » Wed Dec 04, 2019 8:39 pm

Hello babas66,

Did you ever install Xcode 11.x? If yes, then I think I know where the problem is. I had the same problem and spent a lot of time trying to figure out the cause, as the error message from the simulator is not informative at all. So, short description of the problem:

By installing xcode11.x and its additional components, a couple of new subfolders were created in /Library/Developer/* folder. These new files contain the new CoreSimulator framework (of xcode11.x), which includes some changes. One of these is that it no longer allows installing apps to the simulator that do not include a particular key in the plist. Even if you uninstall Xcode 11 and install Xcode 10.1, this file is not replaced by Xcode10.1's equivalent (because the one from Xcode11 is newer, so it does not allow older ones to overwrite it).

Solution:

1. Open Finder, and choose (from Finder's menubar) Go -> Go to Folder and enter /Library/Developer/
2. Delete the /Library/Developer/ folder (or rename it to /Library/XCode11_Developer/)
3. In the terminal, type sudo xcode-select --install and press enter. This will show a dialog asking the user to agree to xcode's terms and conditions and then to install the additional components. Click "I agree" and then "Yes install them"
4. This will create a new folder /Library/Developer/, which will contain the correct additional components (i.e. including the CoreSimulator framework) from Xcode 10.1
5. Now type in the the Terminal sudo xcode-select -s <path_to_xcode10.1.app>

This will hopefully work. Then, make sure you follow the instructions from the previous posts (i.e. to launch the simulator first and then click "Test" in LC)

Kind regards,
Panos
--

babas66
Posts: 9
Joined: Wed May 15, 2019 11:13 am

Re: Unable to start the simulator

Post by babas66 » Thu Dec 05, 2019 3:18 pm

Hello Panos,

thanks you very much for your reply and the description of the problem.

It's work well now !

Effectively, i'have install Xcode 11.x and Xcode 10.1. Your solution to delete worked but it was impossible to launch a device in the simulator with Xcode 10.1, I have reinstall completely 10.1 and the simulator work fine with livecode now.

regards,

Seb

Post Reply

Return to “iOS Deployment”