Bad rendering on iPad only

Getting into LiveCode for iOS? Ask your questions here.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2376
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Bad rendering on iPad only

Post by jmburnod » Wed Oct 02, 2019 4:40 pm

Hi All,
I get a strange rendering with an iOS app. All works well on IDE and standalone for OSX (LC 9.01, iOS 11.4)
• Some objects seem absent (not the same all the time) but i can show some of them when i click them with my finger
• Some btns seems greater than their original size
II tested with acceleratedrendering or not, it seems that is better when it is false
Thanks in advance for your advices
Best regards
Jean-Marc
cEntreeGood.png
cEntreeBad.png

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5104
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Bad rendering on iPad only

Post by jacque » Fri Oct 04, 2019 7:09 am

I see this in some older stacks. A temporary fix sometimes works to force a card redraw:

Code: Select all

set the backcolor of this cd to the effective backcolor of this cd
LC 9.5 has some redraw issues when acceleratedRendering is true.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2376
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: Bad rendering on iPad only

Post by jmburnod » Fri Oct 04, 2019 4:26 pm

Thanks Jacqueline,
I tried:

Code: Select all

set the backcolor of this cd to the effective backcolor of this cd
at opencard
Some problems remain but i can call one message that didn't work before.

I try to track errors with

Code: Select all

on errordialog pExecutionError
	answer "error on line:" && item 2 of line 1 of pExecutionError
ënd errordialog
and i sometime get an error on line 0
I have to understand this as an error at preopencard ?

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5104
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: Bad rendering on iPad only

Post by jacque » Fri Oct 04, 2019 5:26 pm

I'm never sure what error at line 0 is. Most of the time I think it means the compiler doesn't know either. It only knows the script wouldn't execute.

Maybe it's something in one of the LC libraries, but it's hard to tell.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2376
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: Bad rendering on iPad only

Post by jmburnod » Fri Oct 04, 2019 5:42 pm

OK I will track with answer message to know last message executed

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2376
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: Bad rendering on iPad only

Post by jmburnod » Wed Oct 09, 2019 8:02 pm

I've compiled for iOS 13 (LC 9.5 xCode 10.1,) display problems seems fixed with LC 9.5. :D

Post Reply

Return to “iOS Deployment”