Bug Found- Dim light on launch (Video Link included)

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

Bug: Dim-light is shown on launch. (Video link Included)

Post by Jellobus » Wed Jun 12, 2019 6:42 pm

Hello,

This bug has been years since LiveCode 8 introduced. It’s a very critical issue but it’s not been fixed until now.

I thought that it was my PC problem but it was not. I completely formatted my PC and tested again, yet I got the same issue.

Tested Video link: https://youtu.be/SziawUu8Nsc
Tested Devices:
Samsung Galaxy J2, Samsung Galaxy Edge 6, Samsung Galaxy Tab 7, Lenovo Tab, Kobo arc HD 7, Le Pan Tablet — all device show dim light on launch. dim light last 0.1 ~ 11 sec. It depends on specs of devices.


Stack built with:
PC: Windows 10 Pro x64, LC 9.5.0 dp-1, jdk-8u211-windows-x64.exe installed.

Issue:
On Android devices, Dim-light from the bottom of the screen is shown on launch.

Details:
-This issue lasts longer with a stack containing sub-stacks (It’s 10.9Mb as a standalone stack.)
-It lasts less than 0.1~0.2 sec with Samsung Galaxy Edge 6. but it varies greatly from 0.1~10 sec depends on the size of stack and specs of devices.
-Low spec devices will have longer dim light in the black background on launch.

Comment:
-Including or Size of copy file doesn’t affect this issue.
-This issue lasts a very short time at the beginning of the launch, it’s hard to catch.
-To make this more visible, set the background of the test stack to black and use low spec device OR add sub-stacks with enough data.

Steps to reproduce:
1. Make a plain stack. (no code, no copy files)
2. Set the background color to black so that the dim light on launch more visible. (It’s hard to see with gray or white background.)
3. Add sub-stacks containing enough data to be 10Mb as a final standalone stack size. (I added two sub-stacks with all kind of objects in them.)
4. Save it as a standalone stack.
5. Test it.

Result:
Regardless of the existence of sub-stacks, both stacks show dim-light on the launch. but the stack with sub-stack shows longer dim-light.
(From shorter to longer last of dim-light from the bottom of the screen)
stack = stack with files < stack with sub-stacks

Please see the tested Video: https://youtu.be/SziawUu8Nsc
The first stack on the video is a simple raw stack just with text, and the second stack on the video has two sub-stacks.

With this bug, LiveCode won’t be a recommended tool for Android app development. Hope this issue fix ASAP.

Thanks for your time,

Louis

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

-----------

Post by Jellobus » Wed Jun 12, 2019 6:45 pm

-----------
Last edited by Jellobus on Fri Jun 14, 2019 1:28 pm, edited 7 times in total.

bogs
Posts: 3400
Joined: Sat Feb 25, 2017 10:45 pm

Re: Bug Found- Dim light on launch (Video Link included)

Post by bogs » Wed Jun 12, 2019 7:08 pm

What you posted looks like a bug report, did you actually file one at https://quality.livecode.com/ ?
Image

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

Re: Bug Found- Dim light on launch (Video Link included)

Post by Jellobus » Wed Jun 12, 2019 7:16 pm

I filed this bug several times through years, but they never reproduce and confirm this bug. So I filed it again with a video evidence this time.
Please Fix this Bug. It's been years since LC 8 introduced.

LCMark
Livecode Staff Member
Livecode Staff Member
Posts: 1014
Joined: Thu Apr 11, 2013 11:27 am

Re: Bug Found- Dim light on launch (Video Link included)

Post by LCMark » Thu Jun 13, 2019 12:05 pm

@Jellobus: The issue here isn't a bug per-se - its that your main stack is very big (50-60Mb)... In order for the engine to display anything it needs to first load the stack which has been embedded in the executable - decoding and loading 50-60Mb of stackfile into memory is quite a lot, especially on lower powered android hardware.

The solution is to use the standard 'splash stack' approach.

This is where you have a tiny 'splash screen' stack (with maybe an image) which is the stack you choose to embed in the standalone. Then in the 'openStack' handler of the splash stack you *then* load the other stacks and 'go to' them. This means you at least get something displayed on screen whilst the main part of your application is loaded.

Hope this helps!

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

Re: Bug Found- Dim light on launch (Video Link included)

Post by Jellobus » Thu Jun 13, 2019 3:14 pm

@ LCMark: I correct Info. The tested stack was 10.9Mb as .apk file. I was confused with the other stack tested with copy files. ( a lot of copy file doesn't affect the time length of dim-light)

"Splash stack" approach doesn't help because a simple raw stack (no code, no files) shows Dim-light on launch as well. The first stack in the video is a plain raw stack with text. You can see a dim light at the beginning as well. watch 0-20 sec in the video. I launched it 3 times.

Simple plain stack 0-20 sec
Stack + sub stack 21~36sec

In the video, both simple and complex stack show dim light issue on the launch. Just substacks make dim light stay longer.

Also, I tried the splash stack approach but I got the same result.

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

-----------

Post by Jellobus » Thu Jun 13, 2019 3:33 pm

-----------
Last edited by Jellobus on Fri Jun 14, 2019 1:28 pm, edited 2 times in total.

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

-----------

Post by Jellobus » Thu Jun 13, 2019 4:04 pm

-----------
Last edited by Jellobus on Fri Jun 14, 2019 1:28 pm, edited 2 times in total.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6641
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Bug Found- Dim light on launch (Video Link included)

Post by FourthWorld » Thu Jun 13, 2019 6:37 pm

[Duplicate thread merged. Going forward please make only one copy of a given thread, so folks know where to reply and future visitors can find all replies in one place. Thanks.]
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

sphere
Posts: 829
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Bug Found- Dim light on launch (Video Link included)

Post by sphere » Fri Jun 14, 2019 1:11 pm

i had to hold my laptop upside-down, i did not know exactly first what you meant.

I see it too with my stacks, but i've never seen that as a bug.

Ever tried to open Linkedin on a lower spec phone? It is most terrible. I guess it's not made with LC.

There are more apps (not LC) who are slow, so it's more common that it is not immediately displayed.
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

Re: Bug Found- Dim light on launch (Video Link included)

Post by Jellobus » Fri Jun 14, 2019 2:07 pm

@sphere

There are few others complaining of a similar issue as well. That's unknown buffer before the splash screen. This issue shows only with LC apps. Other apps do not show this.

Even with 7.5 Mb of the small plain stack(with one substack), 3~17 seconds of a weird unexpected black screen at the start is absolutely not acceptable for production-ready apps.

Here is more test.

Time delay with a dim-light on launch, model, android version below; (Time was approximately measured)

3~4 seconds on Le Pan tablet(model name: TC802A) (android 4.4.2)
12~17 seconds Kobo arc 7HD (android 4.2.2)
3~4 seconds on Samsung Note2 (android 4.4.2)
1 second on Samsung Galaxy S6 edge (android 7.0)
3~4 seconds on Samsung J2 (android 5.1.1)
8~13 seconds on samsung Tab2 (android 4.2.2)
6~10 seconds on Lenovo tablet 10 inch (android 4.4.2)

sphere
Posts: 829
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Bug Found- Dim light on launch (Video Link included)

Post by sphere » Fri Jun 14, 2019 2:19 pm

I have some apps on android, and with an octa-core it is with every app less than a second. And the APK is approx 15MB.
On my older Wiko Android 6, el cheapo phone quad-core, it maybe was a second.

So i can't say that i find it long or annoying. Nor do i see the longer issue you have.
I also don't see it as a DIM-light,i see just a black screen. But maybe you have set the screen brighter, i don't know.

But if the devs can make it start quicker it could help. But i guess you'll have it with either stack at least fora short period because of the engine i guess.
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

Jellobus
Posts: 257
Joined: Tue Dec 10, 2013 2:53 pm

Re: Bug Found- Dim light on launch (Video Link included)

Post by Jellobus » Fri Jun 14, 2019 8:26 pm

@sphere

I wouldn't care if it last just a second or less. Unfortunately, this issue stays a lot longer than a second in my case. I lost about 60% of my clients since this issue introduced. Most of them were low spec device users. (*This issue was introduced with LC 8+, LC7 was pretty great)

I like to find a walkaround of this issue. I tried a splash stack approach but I had no luck.

I have a few questions for you. Please let me know if you have time.

1. Does your APK have a substack?
2. What is your build environment? (PC or Mac or Linux?)
3. What is your Java SDK version and LC version?


Thanks for your time,

Louis

sphere
Posts: 829
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: Bug Found- Dim light on launch (Video Link included)

Post by sphere » Fri Jun 14, 2019 10:33 pm

Hi Louis,

no sorry i have no substack for mobile. But since my stacks are not that big i use the first card as splash and then move to the second card.
Mostly i do the development on win10-64bits. But since i have a triple boot, i can do Linux(Ubuntu Mate) and MacOs Mojave too.
I use Java JDK_1.8.0_212_x64
LC905rc1 and lc904 and LC950DP1 Indy

Hope this helps you,

regards,
Jerry
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

LCMark
Livecode Staff Member
Livecode Staff Member
Posts: 1014
Joined: Thu Apr 11, 2013 11:27 am

Re: Bug Found- Dim light on launch (Video Link included)

Post by LCMark » Sat Jun 15, 2019 2:16 pm

@jellobus: Those times sound waaay too long for 'just' a plain stack. I've got a old samsung galaxy tab here which has slightly lower hardware specs than your Samsung J2 and with such a stack, startup is a fraction of a second. I think you need to attach the stacks you are using to the bug report so we can see what its doing - there potentially could be some settings you are using in the standalone settings pane, or some inclusions, or a script which is running on startup causing the long pause.

Post Reply

Return to “Android Deployment”