mobilePlaySoundOnChannel on iOS 9.3 iPad3

LiveCode is the premier environment for creating multi-platform solutions for all major operating systems - Windows, Mac OS X, Linux, the Web, Server environments and Mobile platforms. Brand new to LiveCode? Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
trevix
Posts: 425
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

mobilePlaySoundOnChannel on iOS 9.3 iPad3

Post by trevix » Thu Apr 11, 2019 9:54 pm

I have an iPad 3 (model MC706TY/A) with iOS 9.3.5

On the iPad simulator mobilePlaySoundOnChannel TheSoundPath, "Ch1","now" works fine.
In the fisical iPAD, NO sound is coming out.

I set mobileSetSoundChannelVolume "Ch1",100, I checked the correct path, tried with .aif and mp3, with a clean stack to no avail.

Am I missing something?
Thanks
Trevix
Trevix

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4916
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: mobilePlaySoundOnChannel on iOS 9.3 iPad3

Post by jacque » Fri Apr 12, 2019 4:50 pm

Did the device's mute button get accidentally pressed? That happened to someone else here once.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

trevix
Posts: 425
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: mobilePlaySoundOnChannel on iOS 9.3 iPad3

Post by trevix » Fri Apr 12, 2019 4:52 pm

How stupid am I?
Thanks
Trevix

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4916
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: mobilePlaySoundOnChannel on iOS 9.3 iPad3

Post by jacque » Fri Apr 12, 2019 5:00 pm

Sorry, I only mentioned it because the other person didn't know it had happened and it was the only thing I could think of. I've probably been here too long.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

trevix
Posts: 425
Joined: Sat Feb 24, 2007 11:25 pm
Location: Italy
Contact:

Re: mobilePlaySoundOnChannel on iOS 9.3 iPad3

Post by trevix » Fri Apr 12, 2019 6:56 pm

No...I didn't explain my self clearly. Sorry.

It was indeed the mute button !!!!

Thanks
Trevix

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4916
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: mobilePlaySoundOnChannel on iOS 9.3 iPad3

Post by jacque » Fri Apr 12, 2019 7:32 pm

Aha. So it was me being stupid. :) Don't feel bad, it's a subtle thing and you weren't the first to get caught.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

Post Reply

Return to “Getting Started with LiveCode - Experienced Developers”