distorted graphics when using move or set loc

Got a LiveCode personal license? Are you a beginner, hobbyist or educator that's new to LiveCode? This forum is the place to go for help getting started. Welcome!

Moderators: Klaus, FourthWorld, heatherlaine, kevinmiller

xfratboy
Posts: 88
Joined: Fri Mar 05, 2010 9:09 pm

Re: distorted graphics when using move or set loc

Post by xfratboy » Sat Dec 08, 2018 6:38 pm

Lagi Pittas wrote:
Fri Dec 07, 2018 1:53 pm
Hi

I would suggest it's the driver. If it works on some machines and not others. ......
Lagi
Wish that was the fix but unfortunately that doesn't do a thing. I updated to the latest greatest drivers but experienced no improvement. My system is an HP laptop running an Intel 5200 chipset. Slowing movement down to a speed where distortion disappears is like saying, "stop exercising because you get sore afterwards." Problem of soreness may be solved but the purpose of exercise has been defeated. I need my movement to stay at the speed it's at. Basically, I need a graphic or img object to move from one side of the display to the other within a max speed of 600 milliseconds, without the roundness of the graphic being flattened out on the leading edge.

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4702
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: distorted graphics when using move or set loc

Post by jacque » Sat Dec 08, 2018 7:06 pm

It sounds like the only option then is to report the problem and see if the team can fix it.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

dunbarx
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5625
Joined: Wed May 06, 2009 2:28 pm
Location: New York, NY

Re: distorted graphics when using move or set loc

Post by dunbarx » Sat Dec 08, 2018 8:16 pm

Just to confirm, on a MacBook Air and on an Imac, the graphic moves without physical distortion.

The movement itself is not perfectly smooth. This with both the "move" command and the loop which increments the hLoc. Of the two methods, "move" looks better. The slight jerkiness almost looks like some sort of actual object distortion, but I think that is only the overall visual effect, and not any actual"flattening".

@ xFratbot. But is there actual object flattening in what you are seeing? Or is it just much more pronounced jerkiness?

Craig

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4702
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: distorted graphics when using move or set loc

Post by jacque » Sat Dec 08, 2018 8:41 pm

A short video of the screen might help.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

xfratboy
Posts: 88
Joined: Fri Mar 05, 2010 9:09 pm

Re: distorted graphics when using move or set loc

Post by xfratboy » Sat Dec 08, 2018 8:54 pm

flatball.jpg
flatball.jpg (144.32 KiB) Viewed 356 times
Maybe this picture will explain more than words. I just took a picture with my phone of the object moving on my screen.

jacque
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 4702
Joined: Sat Apr 08, 2006 8:31 pm
Location: Minneapolis MN
Contact:

Re: distorted graphics when using move or set loc

Post by jacque » Sat Dec 08, 2018 10:02 pm

Thanks, the picture helps. Is this graphic in a group? It looks exactly the way objects get clipped when they hit a group's margin.
Jacqueline Landman Gay | jacque at hyperactivesw dot com
HyperActive Software | http://www.hyperactivesw.com

dunbarx
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5625
Joined: Wed May 06, 2009 2:28 pm
Location: New York, NY

Re: distorted graphics when using move or set loc

Post by dunbarx » Sun Dec 09, 2018 5:51 am

I am with Jacque here. I thought that the circle was "flattened". This photo definitely looks like it has been truncated.

Try what she implied. Take a circular graphic and group it. Now select the group, and drag either of the left or right handles inwards. You see a truncated graphic, since the group is now smaller than the object it contains. Is this somehow happening in your process?

Craig

richmond62
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 2792
Joined: Fri Feb 19, 2010 10:17 am
Location: Bulgaria
Contact:

Re: distorted graphics when using move or set loc

Post by richmond62 » Sun Dec 09, 2018 10:57 am

IFF the graphic object is grouped (either by itself or in combination with other objects)
surely the 'trick' is to move the group rather than the graphic?

Of course that presupposes the graphic HAS to be grouped;
if it doesn't, then ungroup it and you shouldn't get the "eclipse"
that you are getting at the moment.
-
Eclipse.png
-
Eclipse.livecode.zip
Here's the stack
(1.04 KiB) Downloaded 3 times

capellan
Posts: 527
Joined: Wed Aug 15, 2007 11:09 pm
Contact:

Re: distorted graphics when using move or set loc

Post by capellan » Sun Dec 09, 2018 7:46 pm

If you add the graphic effect "drop shadow" or "outer glow"
to the circle vector graphic, then the clipping effect
is not visible anymore.

Please try adding these effects and post your results.

Could you try this with Older LC versions too?
LC 9.0 and 8.1.10 show this bug in
my own setup.

Al

xfratboy
Posts: 88
Joined: Fri Mar 05, 2010 9:09 pm

Re: distorted graphics when using move or set loc

Post by xfratboy » Mon Dec 10, 2018 4:29 am

capellan wrote:
Sun Dec 09, 2018 7:46 pm
If you add the graphic effect "drop shadow" or "outer glow"
to the circle vector graphic, then the clipping effect
is not visible anymore.

Please try adding these effects and post your results.

Could you try this with Older LC versions too?
LC 9.0 and 8.1.10 show this bug in
my own setup.

Al
There is some improvement visually when adding the effects but it really just seems to cause the distortion to be applied to the shadow and glow area.
jacque wrote:
Sat Dec 08, 2018 10:02 pm
Thanks, the picture helps. Is this graphic in a group? It looks exactly the way objects get clipped when they hit a group's margin.
Object is not inside a group. I've tried placing it inside a group and move the group vs the grc and there was no change.

dunbarx
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5625
Joined: Wed May 06, 2009 2:28 pm
Location: New York, NY

Re: distorted graphics when using move or set loc

Post by dunbarx » Mon Dec 10, 2018 6:29 am

Can you post the stack, or a test stack that shows the same behavior?

Craig

xfratboy
Posts: 88
Joined: Fri Mar 05, 2010 9:09 pm

Re: distorted graphics when using move or set loc

Post by xfratboy » Mon Dec 10, 2018 6:02 pm

dunbarx wrote:
Mon Dec 10, 2018 6:29 am
Can you post the stack, or a test stack that shows the same behavior?

Craig
See attached. It's not pretty but it demonstrates what I'm seeing when I move objects. Adjusting the speed produces an even greater effect. Maybe I'm missing something huge. I appreciate all the help. I just can't believe I'm alone in this problem. I've had this problem for years across several different versions of LC and on numerous different computers. Like I said in my original post, it really only started around the advent of windows 8.
distorted_moving_graphic.zip
(2.03 KiB) Downloaded 3 times

dunbarx
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 5625
Joined: Wed May 06, 2009 2:28 pm
Location: New York, NY

Re: distorted graphics when using move or set loc

Post by dunbarx » Mon Dec 10, 2018 6:54 pm

Hi.

I do see jerkiness, but not the truncated control in your photo.

Speed kills.

The team should see this, if only to confirm that this is the expected behavior of the "move' command.

Craig

xfratboy
Posts: 88
Joined: Fri Mar 05, 2010 9:09 pm

Re: distorted graphics when using move or set loc

Post by xfratboy » Mon Dec 10, 2018 11:36 pm

dunbarx wrote:
Mon Dec 10, 2018 6:54 pm
.....

The team should see this, if only to confirm that this is the expected behavior of the "move' command.

Craig
how does one get in touch with "The Team?"

bogs
Posts: 2378
Joined: Sat Feb 25, 2017 10:45 pm

Re: distorted graphics when using move or set loc

Post by bogs » Mon Dec 10, 2018 11:51 pm

As easily as going to the bug support system, doing a search (to see if it is already reported somewhere), and if not, submitting a report :D
Image

Post Reply

Return to “Getting Started with LiveCode - Complete Beginners”