Standalone In LC 9.0

LiveCode is the premier environment for creating multi-platform solutions for all major operating systems - Windows, Mac OS X, Linux, the Web, Server environments and Mobile platforms. Brand new to LiveCode? Welcome!

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
trags3
Posts: 220
Joined: Wed Apr 09, 2014 1:58 am
Location: Las Vegas, NV

Standalone In LC 9.0

Post by trags3 » Fri Jul 13, 2018 11:38 pm

Hi I have a stack that I am having trouble compiling for iOS. I can compile it for Mac, Windows and Linux. There are commands that won't work with Android ie "open printing to PDF" so I haven't bothered with android yet.
Attached (I hope)is the error message window that pops up. I incluted 2 formats of the same file. the first thing I see that I understand at all is something re: Xcode. Do I need to update my xcode? I havent compiled anything in about 18 months.

Tom
Attachments
Compile Errors.jpg

jmburnod
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 2196
Joined: Sat Dec 22, 2007 5:35 pm
Location: Genève
Contact:

Re: Standalone In LC 9.0

Post by jmburnod » Sat Jul 14, 2018 8:50 am

Hi Tom,
If you have a closestack message please take a look at this thread:
http://forums.livecode.com/viewtopic.php?f=7&t=31221
Best regards
Jean-Marc

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 419
Joined: Fri Feb 06, 2015 4:03 pm

Re: Standalone In LC 9.0

Post by LiveCode_Panos » Sat Jul 14, 2018 4:41 pm

Hello trags3,

This error is probably caused because of a misconfiguration of Xcode.

Which version of MacOS does your Mac run?

Best,
Panos
--

trags3
Posts: 220
Joined: Wed Apr 09, 2014 1:58 am
Location: Las Vegas, NV

Re: Standalone In LC 9.0

Post by trags3 » Mon Jul 16, 2018 1:26 pm

Hi Panos,
I am running OS X Yosemite on a MacBook Air.
I guess i need to update that.
I'll try that!
Thanks

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 419
Joined: Fri Feb 06, 2015 4:03 pm

Re: Standalone In LC 9.0

Post by LiveCode_Panos » Mon Jul 16, 2018 2:26 pm

Hello Tom,

On OSX Yosemite (10.10) you'll need Xcode 7.2 with LC 9.0.0 (and similarly for 9.0.1 RC-1)

You can download older Xcode versions from Apple's downloads website:

https://developer.apple.com/download/more

Best,
Panos
--

Post Reply

Return to “Getting Started with LiveCode - Experienced Developers”