RevVideo on Windows 7... ?

Visuals, audio, animation. Blended, not stirred. If LiveCode is part of your rich media production toolbox, this is the forum for you.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
Jim Mac
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 22
Joined: Wed Jun 28, 2006 9:22 pm

RevVideo on Windows 7... ?

Post by Jim Mac » Mon Jul 09, 2018 6:55 pm

I'm trying to modify code from late 2016... a webcam based inspection tool....
Worked by capturing a still image from webcam using revInitializeVideoGrabber, etc. and analyzing....

I wanted to reuse some of the code in another tool and tweak the interfaces in the current tool.
The2016 standalone still works as expected however..... I can't edit the stack...
I'm using Community 9.0 and it's bombing on most revVideo commands/functions....

I see that the cameraControl is the "new" way to do things but....
1. don't have Indy at my day job....
2. Nothing indicates that revVideo+ has disappeared or that I shouldn't be able to work on updates to my existing stack.

The dictionary indicates revVideoGrabDialog is still part of Livecode even though it mentions
..... QuickTime deprecated in 8.1 (I knew that.... I'm using "VFW")
..... Video library needs to be included in standalones (I knew that.... I'm working in the IDE)
..... Support for "Video Grabber" library on Mac OS ended.... (I knew that.... I'm working in Windows 7)

So choices....
1. See if anyone has worked through this already and has a solution or even a pointer. That's what this post is.
2. Keep trying to figure out where I'm being stupid (a continuing battle)
2. Install an old version of Livecode going backwards untiI I can edit the stacks... I have IT on my side though they are VERY concerned about any non-standard software.
3. Try to create an external to do what I need on my own. Daunting but in the long run probably the best since it frees me from reliance on Livecode functional stability?

Did I miss a notice about deprecating revVideoGrab+?
Does anyone have any advice?

richmond62
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 2664
Joined: Fri Feb 19, 2010 10:17 am
Location: Bulgaria
Contact:

Re: RevVideo on Windows 7... ?

Post by richmond62 » Wed Aug 29, 2018 9:33 am

This looks a lot like your posting 2 years ago . . .

viewtopic.php?f=18&t=27957

I also found THIS in the 8.1.10 release notes:
-
Screen Shot 2018-08-29 at 11.34.13 am.png
-
I don't know if that means that it was removed in 8.1.10
or that is a cumulative list from earlier versions,
and, frankly, I'm too lazy to trawl my way back through
the release notes for each version to establish things.
-
Reading this may help a bit:

viewtopic.php?t=30390

richmond62
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 2664
Joined: Fri Feb 19, 2010 10:17 am
Location: Bulgaria
Contact:

Re: RevVideo on Windows 7... ?

Post by richmond62 » Wed Aug 29, 2018 9:44 am

There seem to be 2 ways to go with this:

1. Use a recent, commercial (licensed) version of LiveCode with cameraControl.

or

2. Go back to LiveCode 7.1.4 (one of my favourite versions), whether licensed or Open Source
and use revVideoGrabber . . . and, of course, make sure you have Quicktime Installed on Windows 7.

Newer versions of software are not necessarily better for some purposes. 8)

Post Reply

Return to “Rich Media”