SDK folder is not valid?

The place to discuss anything and everything about running your LiveCode on Android

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
Peter@multidesk.se
Posts: 126
Joined: Fri Oct 14, 2011 6:53 am

SDK folder is not valid?

Post by Peter@multidesk.se » Fri Feb 02, 2018 11:19 am

Suddenly, the path for Android SDK is missing in my settings.

When I try to choose the same SDK that worked the other day I get:

"The chosen folder is not a valid Android SDK. Please ensure you have installed it correctly.
and enabled support for Android 4.0.3 (API 15)"

I used this SDK two days ago when I last updated my app on Google Play, and now this?

I have not done any updates or installations, so what might have happened, and how do I fix the problem?
Ideally without having to reinstall the entire SDK, If it happened once it can happen again.

I'm on a MAC using LC 9.0.0 (dp11)


///Peter
/*Whats all the fuss with c# ?*/

ameguira@gmail.com
Posts: 20
Joined: Mon Apr 18, 2016 4:57 pm

Re: SDK folder is not valid?

Post by ameguira@gmail.com » Tue Feb 13, 2018 7:42 pm

Hi Peter
I am facing the same problem.
I have installed Android latest version and it seems that LC could be not compatible with it.
I think that we should downgrade the version.
Hope somebody got the solution for us.
Good luck

batmanandjoker
Posts: 1
Joined: Mon Apr 16, 2018 2:04 pm

Re: SDK folder is not valid?

Post by batmanandjoker » Mon Apr 16, 2018 2:12 pm

I also had the hassle of "the chosen listing is not a valid domestic for Android SDK", even when I had updated SDK. (I had an eclipse installation already, that become outdated) as soon as I ran Android Studio with admin rights, i was capable of set the Android SDK path to the sdk folder in my eclipse instalation that I up to date. – Xilconic may 30 'thirteen at 20:thirteen
Admin rights do not solve this hassle. One has to absolutely uninstall and reinstall Android Studio! –
ShowBox Kodi

adxsoft
Posts: 20
Joined: Wed Apr 11, 2018 12:25 pm

Re: SDK folder is not valid?

Post by adxsoft » Wed Feb 20, 2019 6:07 am

I'm having exactly the same problem on Mac OSX 10.11.5, tried LC 8.1.8, LC 9.0.0 and 9.02. Worked yesterday and haven't changed anything overnight so this a major issue for me. Hopefully the cause and solution will be found asap.
Allan

adxsoft
Posts: 20
Joined: Wed Apr 11, 2018 12:25 pm

Re: SDK folder is not valid?

Post by adxsoft » Wed Feb 20, 2019 6:23 am

I solved this for my situation hopefully will work for others.

I noticed that the error message I got said the Android version API 26 was not present. Went into Android Studio, Preferences, Appearance & Behaviour, System Settings,Android SDK and saw Android Version for API 26 was not ticked. I ticked that and clicked the download icon (on the left) and the API 26 version was downloaded automatically.

Once I had the API 26 version of the Android SDK installed I was able to to go to Livecode, Preferences, Mobile Support and set the the location of Android SDK successfully.

So it seems the older version of the Android SDK I was using API 19 (Kitkat) is no longer supported by Livecode.

Can one of LC support team confirm this is the case.

Cheers
Allan

LiveCode_Panos
Livecode Staff Member
Livecode Staff Member
Posts: 583
Joined: Fri Feb 06, 2015 4:03 pm

Re: SDK folder is not valid?

Post by LiveCode_Panos » Mon Feb 25, 2019 3:45 pm

Hello all,

Yes, I confirm you now need to download Android API 26, either using the SDK Manager if you have downloaded only the Android Tools, or as Allan describes if you use Android Studio.

This is a new requirement from Google Play Store.

Hope this helps.

Kind regards,
Panos
--

seoking
Posts: 1
Joined: Fri Mar 22, 2019 1:33 am

Re: SDK folder is not valid?

Post by seoking » Mon Apr 22, 2019 10:22 am

batmanandjoker wrote:
Mon Apr 16, 2018 2:12 pm
I also had the hassle of "the chosen listing is not a valid domestic for Android SDK", even when I had updated SDK. (I had an eclipse installation already, that become outdated) as soon as I ran Android Studio with admin rights, i was capable of set the Android SDK path to the sdk folder in my eclipse instalation that I up to date. – Xilconic may 30 'thirteen at 20:thirteen
Admin rights do not solve this hassle. One has to absolutely uninstall and reinstall Android Studio! –
just wasted a whole lot of time on this problem. My work station is running IntelliJ Ultimate 11 on Windows 7 64-bit. I was setting up my first Android project. Therefore, no SDKs were configured. First I selected the JDK, which was a no-brainer (C:\ProgramFiles (x86)\Java\jdk1.6.0_30). Next comes the part where you need to specify the Android SDK. First you click the elipsis ("...") and then click "Add New". Now here's the kicker... If you look carefully at the dialog box, you'll notice that "Configure new JSDK" is highlighted by default. What you need to do is change the selection to "Android SDK". Now you can select the directory of your Android SDK and you won't get that stupid error message.

I literally wasted about a half an hour before I realized why the app kept telling me "This is not a valid SDK directory." Hopefully this will help someone else having the same problem.

Don here: I had the same trouble in Windows 64 with 11.1.2 and 64bit java. found that only by clicking on the left window could I register my Android SDK

bogs
Posts: 3813
Joined: Sat Feb 25, 2017 10:45 pm

Re: SDK folder is not valid?

Post by bogs » Mon Apr 22, 2019 1:45 pm

I think this is the first time I've seen what I believe to be a bot, quoting another of what I believe to be a bot. Interesting times we live in :D
Image

sphere
Posts: 924
Joined: Sat Sep 27, 2014 10:32 am
Location: Earth, Except when i Jump

Re: SDK folder is not valid?

Post by sphere » Mon Apr 22, 2019 4:16 pm

haha yes, something like that.
The English gramatic was for me very strange to follow, that i quickly stopped reading it.
2018 Worldwide Mobile Market share: Android 84.4% !!!, iOs 15.1%, others 0.1%

modandroidapk
Posts: 1
Joined: Fri May 17, 2019 10:49 am
Contact:

Re: SDK folder is not valid?

Post by modandroidapk » Fri May 17, 2019 11:09 am

adxsoft wrote:
Wed Feb 20, 2019 6:23 am
I solved this for my situation hopefully will work for others.

I noticed that the error message I got said the Android version API 26 was not present. Went into Android Studio, Preferences, Appearance & Behaviour, System Settings,Android SDK and saw Android Version for API 26 was not ticked. I ticked that and clicked the download icon (on the left) and the API 26 version was downloaded automatically.

Once I had the API 26 version of the Android SDK installed I was able to to go to Livecode, Preferences, Mobile Support and set the the location of Android SDK successfully.

So it seems the older version of the Android SDK I was using API 19 (Kitkat) is no longer supported by Livecode.

Can one of LC support team confirm this is the case.

Cheers
Allan
Works just fine, thank you so much Hlowe! : D

Post Reply

Return to “Android Deployment”