Using Navigator with LiveCode: Documentation and Videos

Interested in using the many environmental add-ons and extensions from LiveCode and third parties to the flexible LiveCode environment? This is the place to talk about it.

Moderators: heatherlaine, Klaus, FourthWorld, robinmiller, kevinmiller

Post Reply
geoffcanyon
Posts: 21
Joined: Thu Aug 15, 2013 9:25 am

Using Navigator with LiveCode: Documentation and Videos

Post by geoffcanyon » Thu Jan 04, 2018 10:02 pm

Navigator is an IDE plugin I created many (many) years ago because people were complaining that the built-in tools were too slow/bulky. As computers got faster, that ceased to be an issue, and Navigator languished for about ten years. But I still use it, and a few other people do, too, so I updated it to include support for behaviors and several other new aspects of the IDE.

The (nearly) current documentation is here: Navigator Documentation

Here's a link to all the videos I've created about Navigator: Navigator Videos

Navigator comes as part of the IDE, but that copy is incredibly out of date and you should really download this version and replace the default copy: Download Navigator Here

bogs
Posts: 1733
Joined: Sat Feb 25, 2017 10:45 pm

Re: Using Navigator with LiveCode: Documentation and Videos

Post by bogs » Thu Jan 04, 2018 10:34 pm

< Ears perking >Going quickly to take a look :)

That is pretty slick indeed. Is there a minimum version it works with?
Image

geoffcanyon
Posts: 21
Joined: Thu Aug 15, 2013 9:25 am

Re: Using Navigator with LiveCode: Documentation and Videos

Post by geoffcanyon » Fri Jan 05, 2018 10:38 pm

bogs wrote:
Thu Jan 04, 2018 10:34 pm
Is there a minimum version it works with?
How far back do you want to go? The current version requires behaviors. Not sure how far back that goes, but 6.7.3 at least. The stock version of Navigator that comes with LiveCode is older still, and probably would work back to something <5.0 I also have older versions on some backup somewhere.

bogs
Posts: 1733
Joined: Sat Feb 25, 2017 10:45 pm

Re: Using Navigator with LiveCode: Documentation and Videos

Post by bogs » Sat Jan 06, 2018 12:26 am

Well, I'm currently resurrecting (and mostly using) Mc Oss v3 and 4 with the Lc 6.0.1 and up to about 6.7.11 engines, while at the same time trying to make it compatible with Lc 7.x to current. I don't have any versions of Lc older than 6.0.1, but use 6.5.2 the most, so thats what I'd be shooting for probably.

I did play a bit with the older one as well included with the IDE and those seem to work pretty well in Lc. Currently checking to see if they work in Mc.

The question was prompted by an error in Mc with the current version of Navigator linked about a behavior.
Image
The Lc engine being used was 6.5.2, which has behaviors in it's dictionary, so I am trying to narrow down why the error popped.

*Edit - the Navigator that came with Lc 6.5.2 popped an error, but I suspect that error is related only to the difference in IDE stacks available. The rest of what I had tested worked ok, probably 99% compatible.
Image

geoffcanyon
Posts: 21
Joined: Thu Aug 15, 2013 9:25 am

Re: Using Navigator with LiveCode: Documentation and Videos

Post by geoffcanyon » Sun Jan 07, 2018 6:09 am

Once upon a time I made Navigator MC compatible, but I haven't opened an MC dev environment in fifteen years at least. There are multiple calls in Navigator designed to open LC property inspectors, script editors, etc. The built-in stuff should mostly work, but the rest is going to fail hard.

I've just started updating Navigator to work with LC 8. I don't think anything I've done so far is engine-version-5.5 incompatible, but I'm about to switch to script-only-stacks for behaviors, and the last version before that will be the last 5.5-compatible version of Navigator. I'll be sure to post that when I make the switch, likely tomorrow.

bogs
Posts: 1733
Joined: Sat Feb 25, 2017 10:45 pm

Re: Using Navigator with LiveCode: Documentation and Videos

Post by bogs » Sun Jan 07, 2018 4:50 pm

Thank you for the tips, I appreciate it.

I would never ask someone to create an Mc compatible anything, I hope i didn't give you that impression.
Image

Post Reply

Return to “Using Environment Extensions”