Trouble loading stack file in Community 7.0

Deploying to Windows? Utilizing VB Script execution? This is the place to ask Windows-specific questions.

Moderators: Klaus, FourthWorld, heatherlaine, robinmiller, kevinmiller

Post Reply
SillySoviet
Posts: 7
Joined: Sun May 18, 2014 10:54 pm

Trouble loading stack file in Community 7.0

Post by SillySoviet » Wed May 28, 2014 1:52 am

Hi guys,

Downloaded V 7 DP5, modified a stack on which I'd been working for a while, saved it, and now am getting the "file is not a stack" message when I try to open it. Any clues would be much appreciated. There's no backup file for some reason, so I'm really lost. Thanks.

Simon
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 3901
Joined: Sat Mar 24, 2007 2:54 am
Location: Palo Alto

Re: Trouble loading stack file in Community 7.0

Post by Simon » Wed May 28, 2014 3:33 am

Hi SillySoviet,
Welcome to the forum :)

Bad start for LC 7 :x not to say "they told you to make backups" but they did.
7.0 is still a DP (Developer Preview) and is unstable. They post the dp/rc for us to see if we can break them (and it looks like you did a great job of it!).

Try liveCode 6.6.1 it was the last "stable" release.
Oh,
..."file is not a stack" message when I try to open it.
That message usually occurs when you try to open a stack that was save in a later version. Are you trying to open your stack with a version less than 7.0?
Or is it 7.0 can't open the stack?

Simon
I used to be a newbie but then I learned how to spell teh correctly and now I'm a noob!

SillySoviet
Posts: 7
Joined: Sun May 18, 2014 10:54 pm

Re: Trouble loading stack file in Community 7.0

Post by SillySoviet » Thu May 29, 2014 4:05 am

Simon, you saved my faith in this community! So first: thank you for responding.

I wish I had been that smart so as to save a backup. At this point, I've tried opening the stack in 6.6.1, 6.5, and 7.0. Nothing works.

I can't stand losing hours of work to this kind of lunacy, but then again it's my fault for not saving multiple versions. Good lesson I guess.

Thanks again for your note.

Simon
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 3901
Joined: Sat Mar 24, 2007 2:54 am
Location: Palo Alto

Re: Trouble loading stack file in Community 7.0

Post by Simon » Thu May 29, 2014 4:11 am

If you like you could post the stack here to see if anyone can get it going again.
Oh, actually I think you need 10 post to add attachments and url's.
But post it elsewhere and I can take a look.

I think for now 6.6.1 is for you, but there are a lot of new cool things coming soon!

Simon
I used to be a newbie but then I learned how to spell teh correctly and now I'm a noob!

cannix
Posts: 17
Joined: Mon Jul 07, 2014 12:26 am

Re: Trouble loading stack file in Community 7.0

Post by cannix » Mon Jul 07, 2014 12:36 am

Simon wrote:Hi SillySoviet,
Welcome to the forum :)

Bad start for LC 7 :x not to say "they told you to make backups" but they did.
7.0 is still a DP (Developer Preview) and is unstable. They post the dp/rc for us to see if we can break them (and it looks like you did a great job of it!).

Try liveCode 6.6.1 it was the last "stable" release.
Oh,
..."file is not a stack" message when I try to open it.
That message usually occurs when you try to open a stack that was save in a later version. Are you trying to open your stack with a version less than 7.0?
Or is it 7.0 can't open the stack?

Simon

Community 7.0 DP6 has not updated over a month, when a new version is released it ?

SillySoviet
Posts: 7
Joined: Sun May 18, 2014 10:54 pm

Re: Trouble loading stack file in Community 7.0

Post by SillySoviet » Wed Jul 09, 2014 12:49 pm

I still can't access that file, and I'm hoping with the 7.0 update I will be able to. Otherwise, it's valuable time lost. Will be super-disappointing.

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6715
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Trouble loading stack file in Community 7.0

Post by FourthWorld » Wed Jul 09, 2014 3:58 pm

Was your earlier work done with the Commercial Edition? If so, had you set a password on the stack? The Community edition doesn't understand the format of password-protected stacks, and in some versions will exhibit the behavior you describe.

If instead you've stumbled across one of the very rare cases of actual file corruption, your scripts are still readable:

Code: Select all

on mouseUp
   answer file "Select a stack file:"
   if it is empty then exit to top
   put url ("file:"&* it) into fld "StackDump"
end mouseUp
With that you'll lose the objects, but at least be able to retrieve the scripts.
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

geofhaigh
Posts: 3
Joined: Fri May 08, 2015 10:46 am

Re: Trouble loading stack file in Community 7.0

Post by geofhaigh » Wed Jul 01, 2015 5:13 pm

I am finding LCC 7.0.4 rather unstable on Win7 SP1, with a crash every 1-2 days while doing development. And the most likely event to cause LC to fail is on: Save This stack! when the stack I am trying to save is corrupted. LC simply refuses to open it (silently). You can recover some scripts from text editing the LC-unreadable stack file, and you can resume from the previously saved stack file (stackname.livecode~) by removing "~" from its extension. But it still means losing the maximum amount of work between saves.

Does anyone know of a reliable way to Save This Stack in LCC 7?

FourthWorld
VIP Livecode Opensource Backer
VIP Livecode Opensource Backer
Posts: 6715
Joined: Sat Apr 08, 2006 7:05 am
Location: Los Angeles
Contact:

Re: Trouble loading stack file in Community 7.0

Post by FourthWorld » Wed Jul 01, 2015 5:32 pm

It may be helpful to use the current version, as it will contain any fixes implemented since the version you're using.

Since 7.0.4 there have been eight builds; the current build is 7.0.6 Stable.

Given the number of Windows users, it seems the problem may not be so easily reproducible as just saving alone; that would have been picked up in the team's automated testing tool, and many other users as well.

I suspect there may be an issue with a specific element in your stack, possibly bad image data or odd bytes in a field object. If so, replacing that one object should make the issue go away.

Have you filed a bug report on this? How many cards in the stack, and roughly how many objects?
Richard Gaskin
Community volunteer LiveCode Community Liaison

LiveCode development, training, and consulting services: Fourth World Systems: http://FourthWorld.com
LiveCode User Group on Facebook : http://FaceBook.com/groups/LiveCodeUsers/

tomBTG
Livecode Opensource Backer
Livecode Opensource Backer
Posts: 66
Joined: Fri Nov 25, 2011 6:42 pm
Location: Kansas City
Contact:

Re: Trouble loading stack file in Community 7.0

Post by tomBTG » Thu Jul 02, 2015 3:18 pm

geofhaigh wrote:I am finding LCC 7.0.4 rather unstable on Win7 SP1, with a crash every 1-2 days while doing development. And the most likely event to cause LC to fail is on: Save This stack! when the stack I am trying to save is corrupted. LC simply refuses to open it (silently). You can recover some scripts from text editing the LC-unreadable stack file, and you can resume from the previously saved stack file (stackname.livecode~) by removing "~" from its extension. But it still means losing the maximum amount of work between saves.

Does anyone know of a reliable way to Save This Stack in LCC 7?
Hi,
I had a string of frequent crashes in LC 7.0.5 on Win7. I never pinned down the cause, but found that reinstalling LC helped. (If you have old versions to uninstall, do that first.)
Tom

Post Reply

Return to “Windows”